summaryrefslogtreecommitdiff
path: root/indra/media_plugins/base/CMakeLists.txt
diff options
context:
space:
mode:
authorMonty Brandenberg <monty@lindenlab.com>2010-12-09 11:07:50 -0500
committerMonty Brandenberg <monty@lindenlab.com>2010-12-09 11:07:50 -0500
commitb9cf73c29b4b87a391c78415e4c09c31b4ac045c (patch)
treed843f4e78bc6874001cb81fc993cc59d0a179a83 /indra/media_plugins/base/CMakeLists.txt
parenta59c43f1adff35107e59fdfc3016d4329324bbaf (diff)
parentd9b4570883652d647c05083c18fac1a088efd6e2 (diff)
merge from http://hg.secondlife.com/viewer-development
Diffstat (limited to 'indra/media_plugins/base/CMakeLists.txt')
-rw-r--r--indra/media_plugins/base/CMakeLists.txt8
1 files changed, 8 insertions, 0 deletions
diff --git a/indra/media_plugins/base/CMakeLists.txt b/indra/media_plugins/base/CMakeLists.txt
index f8d2dabc6c..3ad94b0c64 100644
--- a/indra/media_plugins/base/CMakeLists.txt
+++ b/indra/media_plugins/base/CMakeLists.txt
@@ -25,6 +25,14 @@ include_directories(
### media_plugin_base
+if(NOT WORD_SIZE EQUAL 32)
+ if(WINDOWS)
+ add_definitions(/FIXED:NO)
+ else(WINDOWS) # not windows therefore gcc LINUX and DARWIN
+ add_definitions(-fPIC)
+ endif(WINDOWS)
+endif(NOT WORD_SIZE EQUAL 32)
+
set(media_plugin_base_SOURCE_FILES
media_plugin_base.cpp
)