summaryrefslogtreecommitdiff
path: root/indra/mac_updater/CMakeLists.txt
diff options
context:
space:
mode:
authorKartic Krishnamurthy <drunkensufi@lindenlab.com>2008-11-07 00:07:44 +0000
committerKartic Krishnamurthy <drunkensufi@lindenlab.com>2008-11-07 00:07:44 +0000
commitb2bfb128e7d30e1cdb293a2ac192a0cbe63fe528 (patch)
tree29fbacff21395f53f5b029796f90a34638118fe9 /indra/mac_updater/CMakeLists.txt
parent24ff4831f2a24045b3d06e81581dbe6d20475722 (diff)
Merged into release with command:
================================= svn merge -r100865:101402 svn+ssh://svn/svn/linden/branches/purge-dpo-code-for-merge . QAR-951 : Sandbox QA for DEV 20842 - Ensure DPO is not enabled accidentally QAR-967 : Merge Build for DEV 20842 - Ensure DPOis not enabled accidentally QA tested: Beast, Oskar DEV's fulfilled as part of this branch: ====================================== DEV-20842 Prevent accidental activation of DPO procs DEV-23028 Mac build fails - link error dual inclusion DEV-20824 VWR-9255: Build fails on mac_updater and mac_crash_logger targets due to info.plist problems DEV-22997 Xcode project: 'server' target has no dependencies DEV-23353 Friend request custom messages come through as an asset tag. DEV-23309 Voice Chat Indicator does not show active voice status DEV-23187 Can't teleport to home location
Diffstat (limited to 'indra/mac_updater/CMakeLists.txt')
-rw-r--r--indra/mac_updater/CMakeLists.txt13
1 files changed, 5 insertions, 8 deletions
diff --git a/indra/mac_updater/CMakeLists.txt b/indra/mac_updater/CMakeLists.txt
index 3ac5aeebd5..0eac76fa69 100644
--- a/indra/mac_updater/CMakeLists.txt
+++ b/indra/mac_updater/CMakeLists.txt
@@ -42,7 +42,6 @@ list(APPEND mac_updater_SOURCE_FILES ${mac_updater_HEADER_FILES})
set(mac_updater_RESOURCE_FILES
- Info.plist
AutoUpdater.nib/
)
set_source_files_properties(
@@ -50,19 +49,18 @@ set_source_files_properties(
PROPERTIES
HEADER_FILE_ONLY TRUE
)
-set_source_files_properties(
- Info.plist
- PROPERTIES
- MACOSX_PACKAGE_LOCATION . # will it blend? + poppy
- )
SOURCE_GROUP("Resources" FILES ${mac_updater_RESOURCE_FILES})
list(APPEND mac_updater_SOURCE_FILES ${mac_updater_RESOURCE_FILES})
-
add_executable(mac-updater
MACOSX_BUNDLE
${mac_updater_SOURCE_FILES})
+set_target_properties(mac-updater
+ PROPERTIES
+ MACOSX_BUNDLE_INFO_PLIST ${CMAKE_CURRENT_SOURCE_DIR}/Info.plist
+ )
+
target_link_libraries(mac-updater
${LLVFS_LIBRARIES}
${CURL_LIBRARIES}
@@ -79,4 +77,3 @@ add_custom_command(
${CMAKE_CURRENT_BINARY_DIR}/${CMAKE_CFG_INTDIR}/mac-updater.app/Contents/Resources/AutoUpdater.nib
)
-