summaryrefslogtreecommitdiff
path: root/indra/mac_updater/CMakeLists.txt
diff options
context:
space:
mode:
authorBryan O'Sullivan <bos@lindenlab.com>2008-06-02 21:14:31 +0000
committerBryan O'Sullivan <bos@lindenlab.com>2008-06-02 21:14:31 +0000
commit9db949eec327df4173fde3de934a87bedb0db13c (patch)
treeaeffa0f0e68b1d2ceb74d460cbbd22652c9cd159 /indra/mac_updater/CMakeLists.txt
parent419e13d0acaabf5e1e02e9b64a07648bce822b2f (diff)
svn merge -r88066:88786 svn+ssh://svn.lindenlab.com/svn/linden/branches/cmake-9-merge
dataserver-is-deprecated for-fucks-sake-whats-with-these-commit-markers
Diffstat (limited to 'indra/mac_updater/CMakeLists.txt')
-rw-r--r--indra/mac_updater/CMakeLists.txt49
1 files changed, 49 insertions, 0 deletions
diff --git a/indra/mac_updater/CMakeLists.txt b/indra/mac_updater/CMakeLists.txt
new file mode 100644
index 0000000000..39aa4d2b15
--- /dev/null
+++ b/indra/mac_updater/CMakeLists.txt
@@ -0,0 +1,49 @@
+# -*- cmake -*-
+
+project(mac_updater)
+
+include(00-Common)
+include(CURL)
+include(LLCommon)
+include(LLVFS)
+include(Linking)
+
+include_directories(
+ ${LLCOMMON_INCLUDE_DIRS}
+ ${LLVFS_INCLUDE_DIRS}
+ )
+
+set(mac_updater_SOURCE_FILES
+ mac_updater.cpp
+ FSCopyObject.c
+ GenLinkedList.c
+ MoreFilesX.c
+ )
+
+set(mac_updater_HEADER_FILES
+ CMakeLists.txt
+
+ FSCopyObject.h
+ GenLinkedList.h
+ MoreFilesX.h
+ )
+
+set_source_files_properties(
+ FSCopyObject.c
+ MoreFilesX.c
+ PROPERTIES
+ COMPILE_FLAGS -Wno-deprecated-declarations
+ )
+
+set_source_files_properties(${mac_updater_HEADER_FILES}
+ PROPERTIES HEADER_FILE_ONLY TRUE)
+
+list(APPEND mac_updater_SOURCE_FILES ${mac_updater_HEADER_FILES})
+
+add_executable(mac-updater ${mac_updater_SOURCE_FILES})
+
+target_link_libraries(mac-updater
+ ${LLVFS_LIBRARIES}
+ ${CURL_LIBRARIES}
+ ${LLCOMMON_LIBRARIES}
+ )