summaryrefslogtreecommitdiff
path: root/indra/mac_updater/CMakeLists.txt
diff options
context:
space:
mode:
authorSteven Bennetts <steve@lindenlab.com>2008-08-12 17:29:50 +0000
committerSteven Bennetts <steve@lindenlab.com>2008-08-12 17:29:50 +0000
commit80be4c1d2d73982ea2df6dd7ef3fc3465416c882 (patch)
tree9c5958572368be494b6302db8b03967a2c67b7ad /indra/mac_updater/CMakeLists.txt
parenta09f7d41efdb945755efaeb07f7418c1f6e2a78b (diff)
QAR-767 Combined maint-render-7 and maint-viewer-9 merge
merge release@93398 viewer-merge-1@94007 -> release dataserver-is-deprecated
Diffstat (limited to 'indra/mac_updater/CMakeLists.txt')
-rw-r--r--indra/mac_updater/CMakeLists.txt35
1 files changed, 34 insertions, 1 deletions
diff --git a/indra/mac_updater/CMakeLists.txt b/indra/mac_updater/CMakeLists.txt
index 39aa4d2b15..3ac5aeebd5 100644
--- a/indra/mac_updater/CMakeLists.txt
+++ b/indra/mac_updater/CMakeLists.txt
@@ -40,10 +40,43 @@ set_source_files_properties(${mac_updater_HEADER_FILES}
list(APPEND mac_updater_SOURCE_FILES ${mac_updater_HEADER_FILES})
-add_executable(mac-updater ${mac_updater_SOURCE_FILES})
+
+set(mac_updater_RESOURCE_FILES
+ Info.plist
+ AutoUpdater.nib/
+ )
+set_source_files_properties(
+ ${mac_updater_RESOURCE_FILES}
+ PROPERTIES
+ HEADER_FILE_ONLY TRUE
+ )
+set_source_files_properties(
+ Info.plist
+ PROPERTIES
+ MACOSX_PACKAGE_LOCATION . # will it blend? + poppy
+ )
+SOURCE_GROUP("Resources" FILES ${mac_updater_RESOURCE_FILES})
+list(APPEND mac_updater_SOURCE_FILES ${mac_updater_RESOURCE_FILES})
+
+
+add_executable(mac-updater
+ MACOSX_BUNDLE
+ ${mac_updater_SOURCE_FILES})
target_link_libraries(mac-updater
${LLVFS_LIBRARIES}
${CURL_LIBRARIES}
${LLCOMMON_LIBRARIES}
)
+
+add_custom_command(
+ TARGET mac-updater POST_BUILD
+ COMMAND ${CMAKE_COMMAND}
+ ARGS
+ -E
+ copy_directory
+ ${CMAKE_CURRENT_SOURCE_DIR}/AutoUpdater.nib
+ ${CMAKE_CURRENT_BINARY_DIR}/${CMAKE_CFG_INTDIR}/mac-updater.app/Contents/Resources/AutoUpdater.nib
+ )
+
+