summaryrefslogtreecommitdiff
path: root/indra/mac_updater/CMakeLists.txt
diff options
context:
space:
mode:
authorOz Linden <oz@lindenlab.com>2013-01-03 17:32:49 -0500
committerOz Linden <oz@lindenlab.com>2013-01-03 17:32:49 -0500
commit80b734575d7205c91b214b69cebf87c242cd9388 (patch)
tree53785619f7ac8769d6722392d5f7c8c9a4fbec75 /indra/mac_updater/CMakeLists.txt
parent0b1d70fd71231c97e3489dfde07e327517cb5d7d (diff)
parent835660bbb2158d6306e51928fa861e32ad60e8c0 (diff)
merge up to 3.4.4-beta3, new havok license, and new boost and icu4c builds
Diffstat (limited to 'indra/mac_updater/CMakeLists.txt')
-rw-r--r--indra/mac_updater/CMakeLists.txt22
1 files changed, 3 insertions, 19 deletions
diff --git a/indra/mac_updater/CMakeLists.txt b/indra/mac_updater/CMakeLists.txt
index 7382e912bf..00dcedecaa 100644
--- a/indra/mac_updater/CMakeLists.txt
+++ b/indra/mac_updater/CMakeLists.txt
@@ -18,14 +18,10 @@ include_directories(
)
set(mac_updater_SOURCE_FILES
- main.m
- MacUpdaterAppDelegate.mm
mac_updater.cpp
)
set(mac_updater_HEADER_FILES
- MacUpdaterAppDelegate.h
- mac_updater.h
CMakeLists.txt
)
@@ -36,7 +32,7 @@ list(APPEND mac_updater_SOURCE_FILES ${mac_updater_HEADER_FILES})
set(mac_updater_RESOURCE_FILES
- AutoUpdater.nib
+ AutoUpdater.nib/
)
set_source_files_properties(
${mac_updater_RESOURCE_FILES}
@@ -52,19 +48,13 @@ add_executable(mac-updater
set_target_properties(mac-updater
PROPERTIES
- MACOSX_BUNDLE_INFO_PLIST ${CMAKE_CURRENT_SOURCE_DIR}/MacUpdater-Info.plist
+ MACOSX_BUNDLE_INFO_PLIST ${CMAKE_CURRENT_SOURCE_DIR}/Info.plist
)
-find_library(COCOA_LIBRARY Cocoa)
-find_library(IOKIT_LIBRARY IOKit)
-
target_link_libraries(mac-updater
${LLVFS_LIBRARIES}
${OPENSSL_LIBRARIES}
${CRYPTO_LIBRARIES}
- ${COCOA_LIBRARIES}
- ${BOOST_FILESYSTEM_LIBRARY}
- ${IOKIT_LIBRARY}
${CURL_LIBRARIES}
${CARES_LIBRARIES}
${LLCOMMON_LIBRARIES}
@@ -72,16 +62,10 @@ target_link_libraries(mac-updater
add_custom_command(
TARGET mac-updater POST_BUILD
-# COMMAND ${CMAKE_COMMAND}
-# ARGS
-# -E
-# copy_directory
-# ${CMAKE_CURRENT_SOURCE_DIR}/AutoUpdater.nib
-# ${CMAKE_CURRENT_BINARY_DIR}/${CMAKE_CFG_INTDIR}/mac-updater.app/Contents/Resources/AutoUpdater.nib
COMMAND ${CMAKE_COMMAND}
ARGS
-E
- copy
+ copy_directory
${CMAKE_CURRENT_SOURCE_DIR}/AutoUpdater.nib
${CMAKE_CURRENT_BINARY_DIR}/${CMAKE_CFG_INTDIR}/mac-updater.app/Contents/Resources/AutoUpdater.nib
)