summaryrefslogtreecommitdiff
path: root/indra/mac_crash_logger/CMakeLists.txt
diff options
context:
space:
mode:
authorpalange <palange@lindenlab.com>2009-11-02 12:12:32 -0800
committerpalange <palange@lindenlab.com>2009-11-02 12:12:32 -0800
commitcf0c0e182441e442db78ded1a7139818502ae066 (patch)
tree614ceaf88fdfea9e2d42c1c4137642793d505b5d /indra/mac_crash_logger/CMakeLists.txt
parent53c972a521cbb92c6c9390c41b250a41dc22cd5a (diff)
Added build time script to help deploy shared libs for an arbitrary executable.
indra/cmake/DeploySharedLibs.cmake is the script. LLSharedLibs.cmake contains a macro to ease adding DeployShaerdLibs to a targets build. Example usage to the mac-crash-reporter. Multiplatform and more to come soon. Reviewed by brad.
Diffstat (limited to 'indra/mac_crash_logger/CMakeLists.txt')
-rw-r--r--indra/mac_crash_logger/CMakeLists.txt5
1 files changed, 5 insertions, 0 deletions
diff --git a/indra/mac_crash_logger/CMakeLists.txt b/indra/mac_crash_logger/CMakeLists.txt
index daf3e10857..1d6494fecf 100644
--- a/indra/mac_crash_logger/CMakeLists.txt
+++ b/indra/mac_crash_logger/CMakeLists.txt
@@ -10,6 +10,7 @@ include(LLMessage)
include(LLVFS)
include(LLXML)
include(Linking)
+include(LLSharedLibs)
include_directories(
${LLCOMMON_INCLUDE_DIRS}
@@ -74,3 +75,7 @@ add_custom_command(
${CMAKE_CURRENT_BINARY_DIR}/${CMAKE_CFG_INTDIR}/mac-crash-logger.app/Contents/Resources/CrashReporter.nib
)
+ll_deploy_sharedlibs_command(
+ mac-crash-logger
+ "${SHARED_LIB_STAGING_DIR}/${CMAKE_CFG_INTDIR};${ARCH_PREBUILT_DIRS}"
+ "../Resources")