summaryrefslogtreecommitdiff
path: root/indra/lscript/lscript_compile/CMakeLists.txt
diff options
context:
space:
mode:
authordeveloper@Developer-PC <developer@Developer-PC>2012-09-21 22:21:42 -0700
committerdeveloper@Developer-PC <developer@Developer-PC>2012-09-21 22:21:42 -0700
commitecf72da021d16168688a833e776e8a76e80ee4d6 (patch)
treec61de5560a008cba335d41e567fb48fade638361 /indra/lscript/lscript_compile/CMakeLists.txt
parent2d36f9b98a95a384f712c711bf9fc4cbe53780aa (diff)
More windows build fixes
Diffstat (limited to 'indra/lscript/lscript_compile/CMakeLists.txt')
-rw-r--r--indra/lscript/lscript_compile/CMakeLists.txt4
1 files changed, 3 insertions, 1 deletions
diff --git a/indra/lscript/lscript_compile/CMakeLists.txt b/indra/lscript/lscript_compile/CMakeLists.txt
index 134703eed3..13cbd3ffd2 100644
--- a/indra/lscript/lscript_compile/CMakeLists.txt
+++ b/indra/lscript/lscript_compile/CMakeLists.txt
@@ -113,8 +113,10 @@ if (WINDOWS)
${CMAKE_CURRENT_BINARY_DIR}/indra.y.cpp
${CMAKE_CURRENT_BINARY_DIR}/indra.y.hpp
COMMAND ${CMAKE_CURRENT_SOURCE_DIR}/bison.bat
+ ARGS
${BISON} ${M4_PATH}
- ${CMAKE_CURRENT_BINARY_DIR}/indra.y.cpp
+ -p indra_
+ -d -o ${CMAKE_CURRENT_BINARY_DIR}/indra.y.cpp
${CMAKE_CURRENT_SOURCE_DIR}/indra.y
DEPENDS
${CMAKE_CURRENT_SOURCE_DIR}/bison.bat