summaryrefslogtreecommitdiff
path: root/indra/lscript/lscript_compile/CMakeLists.txt
diff options
context:
space:
mode:
authorNyx Linden <nyx@lindenlab.com>2012-09-19 17:05:56 +0000
committerNyx Linden <nyx@lindenlab.com>2012-09-19 17:05:56 +0000
commit49caededb4bf5beb8b87ebee034c1d969968af4d (patch)
treec10775b72f3fcd7b3cda9e51bb87a30d56d84c42 /indra/lscript/lscript_compile/CMakeLists.txt
parent8b2cb3766e3ed546994f81518983283e68263b09 (diff)
BUILDFIX: enabling the building of the viewer/appearance backend with headless mesa
Diffstat (limited to 'indra/lscript/lscript_compile/CMakeLists.txt')
-rw-r--r--indra/lscript/lscript_compile/CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/indra/lscript/lscript_compile/CMakeLists.txt b/indra/lscript/lscript_compile/CMakeLists.txt
index 3ed2892e0e..134703eed3 100644
--- a/indra/lscript/lscript_compile/CMakeLists.txt
+++ b/indra/lscript/lscript_compile/CMakeLists.txt
@@ -95,6 +95,7 @@ add_custom_command(
${CMAKE_CURRENT_BINARY_DIR}/indra.l.cpp
COMMAND ${FLEX}
ARGS
+ -P indra_
-o${CMAKE_CURRENT_BINARY_DIR}/indra.l.cpp
${CMAKE_CURRENT_SOURCE_DIR}/indra.l
DEPENDS ${CMAKE_CURRENT_SOURCE_DIR}/indra.l
@@ -128,6 +129,7 @@ else (WINDOWS)
COMMAND
${BISON}
ARGS
+ -p indra_
-d -o ${CMAKE_CURRENT_BINARY_DIR}/indra.y.cpp
${CMAKE_CURRENT_SOURCE_DIR}/indra.y
DEPENDS