summaryrefslogtreecommitdiff
path: root/indra/llwindow/CMakeLists.txt
diff options
context:
space:
mode:
authorErik Kundiman <erik@megapahit.org>2023-08-21 16:25:38 +0800
committerErik Kundiman <erik@megapahit.org>2023-08-21 16:25:38 +0800
commit99e4f282ba8df6dcaa3032fa1bfbb5f88884d9a6 (patch)
tree43d40b7f1d7d44c0386de94ef7f29165772259c5 /indra/llwindow/CMakeLists.txt
parentb8e727b023876c34ae3b1fca0f598c8b2dbe4bcd (diff)
Darwin & any platform can, and should, use SDL
The alt mouse click to cam is broken for now on macOS, but this is the path we've chosen.
Diffstat (limited to 'indra/llwindow/CMakeLists.txt')
-rw-r--r--indra/llwindow/CMakeLists.txt4
1 files changed, 2 insertions, 2 deletions
diff --git a/indra/llwindow/CMakeLists.txt b/indra/llwindow/CMakeLists.txt
index cc44c1e2a1..9cf31d60d5 100644
--- a/indra/llwindow/CMakeLists.txt
+++ b/indra/llwindow/CMakeLists.txt
@@ -64,7 +64,7 @@ include_directories(${CMAKE_SOURCE_DIR}/llrender)
# Libraries on which this library depends, needed for Linux builds
# Sort by high-level to low-level
-if (LINUX OR CMAKE_SYSTEM_NAME MATCHES "FreeBSD")
+if (USESYSTEMLIBS)
list(APPEND viewer_SOURCE_FILES
llkeyboardsdl.cpp
llwindowsdl.cpp
@@ -87,7 +87,7 @@ if (LINUX OR CMAKE_SYSTEM_NAME MATCHES "FreeBSD")
)
endif (BUILD_HEADLESS)
-endif (LINUX OR CMAKE_SYSTEM_NAME MATCHES "FreeBSD")
+endif (USESYSTEMLIBS)
if (DARWIN)
list(APPEND llwindow_SOURCE_FILES