summaryrefslogtreecommitdiff
path: root/indra/llwindow/CMakeLists.txt
diff options
context:
space:
mode:
authorErik Kundiman <erik@megapahit.org>2023-07-29 20:58:27 +0800
committerErik Kundiman <erik@megapahit.org>2023-07-29 20:58:27 +0800
commit6e4f095baa8e33effe80b68ddf834a3b80f2bb67 (patch)
tree3d131c6056d3b6132226ff69da54c11800809a56 /indra/llwindow/CMakeLists.txt
parentd74367b40d3a2680bbc371b72e294419093e1d83 (diff)
Setting BUILD_SHARED_LIBS on is now possible
by removing cyclic dependencies, and allowing shlib undefined on SLPlugin alone.
Diffstat (limited to 'indra/llwindow/CMakeLists.txt')
-rw-r--r--indra/llwindow/CMakeLists.txt5
1 files changed, 4 insertions, 1 deletions
diff --git a/indra/llwindow/CMakeLists.txt b/indra/llwindow/CMakeLists.txt
index c2989e84c9..53b104dab2 100644
--- a/indra/llwindow/CMakeLists.txt
+++ b/indra/llwindow/CMakeLists.txt
@@ -51,7 +51,7 @@ set(llwindow_LINK_LIBRARIES
llcommon
llimage
llmath
- llrender
+ #llrender
llfilesystem
llxml
ll::glh_linear
@@ -59,6 +59,9 @@ set(llwindow_LINK_LIBRARIES
ll::uilibraries
ll::SDL
)
+
+include_directories(${CMAKE_SOURCE_DIR}/llrender)
+
# Libraries on which this library depends, needed for Linux builds
# Sort by high-level to low-level
if (LINUX OR CMAKE_SYSTEM_NAME MATCHES "FreeBSD")