summaryrefslogtreecommitdiff
path: root/indra/llvfs/CMakeLists.txt
diff options
context:
space:
mode:
authorSeth ProductEngine <slitovchuk@productengine.com>2010-12-17 22:16:14 +0200
committerSeth ProductEngine <slitovchuk@productengine.com>2010-12-17 22:16:14 +0200
commit4e150d3271334e17bca0b9b47022fa3c529dc8c8 (patch)
tree0eccffee6a9b0a9f63aedb6c5a5c4a9c7b65dd15 /indra/llvfs/CMakeLists.txt
parentaab5759467a4d24aaebbdc95f052fbcb46826657 (diff)
STORM-477 WIP Re-implemented LLDir::getNextFileInDir() as an iterator object.
- Added a class implementing directory entries iteration with pattern matching which is used in unit tests instead of LLDir::getNextFileInDir. STORM-550 FIXED Fixed LLDir unit test which failed for some complex wildcard combinations.
Diffstat (limited to 'indra/llvfs/CMakeLists.txt')
-rw-r--r--indra/llvfs/CMakeLists.txt7
1 files changed, 7 insertions, 0 deletions
diff --git a/indra/llvfs/CMakeLists.txt b/indra/llvfs/CMakeLists.txt
index 722f4e2bfd..a3782d824b 100644
--- a/indra/llvfs/CMakeLists.txt
+++ b/indra/llvfs/CMakeLists.txt
@@ -12,6 +12,7 @@ include_directories(
set(llvfs_SOURCE_FILES
lldir.cpp
+ lldiriterator.cpp
lllfsthread.cpp
llpidlock.cpp
llvfile.cpp
@@ -24,6 +25,7 @@ set(llvfs_HEADER_FILES
lldir.h
lldirguard.h
+ lldiriterator.h
lllfsthread.h
llpidlock.h
llvfile.h
@@ -60,6 +62,11 @@ list(APPEND llvfs_SOURCE_FILES ${llvfs_HEADER_FILES})
add_library (llvfs ${llvfs_SOURCE_FILES})
+target_link_libraries(llvfs
+ ${BOOST_FILESYSTEM_LIBRARY}
+ ${BOOST_SYSTEM_LIBRARY}
+ )
+
if (DARWIN)
include(CMakeFindFrameworks)
find_library(CARBON_LIBRARY Carbon)