summaryrefslogtreecommitdiff
path: root/indra/llui/CMakeLists.txt
diff options
context:
space:
mode:
authorAdam Moss <moss@lindenlab.com>2009-08-21 21:52:21 +0000
committerAdam Moss <moss@lindenlab.com>2009-08-21 21:52:21 +0000
commitc3cbd049859c058526ae9a07a5cbfa7e51085943 (patch)
tree80f74a033a2f56f465cd4a67fa3e11a00bc18248 /indra/llui/CMakeLists.txt
parent87be6648d50efc55785e2298a9ed6ec0546da564 (diff)
svn merge -r130238:130240 svn+ssh://svn.lindenlab.com/svn/linden/branches/linux-updater-6
QAR-1771 Linux Viewer Autoupdater + XUI-parse refactoring
Diffstat (limited to 'indra/llui/CMakeLists.txt')
-rw-r--r--indra/llui/CMakeLists.txt12
1 files changed, 5 insertions, 7 deletions
diff --git a/indra/llui/CMakeLists.txt b/indra/llui/CMakeLists.txt
index e8d95b44a5..7f71ff6a53 100644
--- a/indra/llui/CMakeLists.txt
+++ b/indra/llui/CMakeLists.txt
@@ -12,6 +12,7 @@ include(LLRender)
include(LLWindow)
include(LLVFS)
include(LLXML)
+include(LLXUIXML)
include_directories(
${LLAUDIO_INCLUDE_DIRS}
@@ -23,6 +24,7 @@ include_directories(
${LLWINDOW_INCLUDE_DIRS}
${LLVFS_INCLUDE_DIRS}
${LLXML_INCLUDE_DIRS}
+ ${LLXUIXML_INCLUDE_DIRS}
)
set(llui_SOURCE_FILES
@@ -44,7 +46,6 @@ set(llui_SOURCE_FILES
llfocusmgr.cpp
llfunctorregistry.cpp
lliconctrl.cpp
- llinitparam.cpp
llkeywords.cpp
lllayoutstack.cpp
lllineeditor.cpp
@@ -82,9 +83,8 @@ set(llui_SOURCE_FILES
lltextbox.cpp
lltexteditor.cpp
lltextparser.cpp
- lltrans.cpp
+ lltransutil.cpp
llui.cpp
- lluicolor.cpp
lluicolortable.cpp
lluictrl.cpp
lluictrlfactory.cpp
@@ -121,7 +121,6 @@ set(llui_HEADER_FILES
llhandle.h
llhtmlhelp.h
lliconctrl.h
- llinitparam.h
llkeywords.h
lllayoutstack.h
lllazyvalue.h
@@ -136,7 +135,6 @@ set(llui_HEADER_FILES
llpanel.h
llprogressbar.h
llradiogroup.h
- llregistry.h
llresizebar.h
llresizehandle.h
llresmgr.h
@@ -161,8 +159,7 @@ set(llui_HEADER_FILES
lltextbox.h
lltexteditor.h
lltextparser.h
- lltrans.h
- lluicolor.h
+ lltransutil.h
lluicolortable.h
lluiconstants.h
lluictrlfactory.h
@@ -191,6 +188,7 @@ target_link_libraries(llui
llwindow
llimage
llvfs # ugh, just for LLDir
+ llxuixml
llxml
llcommon # must be after llimage, llwindow, llrender
llmath