summaryrefslogtreecommitdiff
path: root/indra/llrender/CMakeLists.txt
diff options
context:
space:
mode:
authorJames Cook <james@lindenlab.com>2009-04-20 16:24:21 +0000
committerJames Cook <james@lindenlab.com>2009-04-20 16:24:21 +0000
commit9b2d9c6e6e43f5600be64c65e42c373a199a3e1d (patch)
treeca16f9a775bcd025671a95a72c12664e142acc47 /indra/llrender/CMakeLists.txt
parent5c2fd1e4fe304e1b6f6d4136f0d1fd3028c3dddd (diff)
Retry. Build system fixes for library-library dependencies, ported from skinning-7. OK by CG.
svn merge -r117623:117624 svn+ssh://svn.lindenlab.com/svn/linden/branches/skinning/skinning-7
Diffstat (limited to 'indra/llrender/CMakeLists.txt')
-rw-r--r--indra/llrender/CMakeLists.txt7
1 files changed, 7 insertions, 0 deletions
diff --git a/indra/llrender/CMakeLists.txt b/indra/llrender/CMakeLists.txt
index 0bdb55f9d0..0bb835970f 100644
--- a/indra/llrender/CMakeLists.txt
+++ b/indra/llrender/CMakeLists.txt
@@ -3,6 +3,7 @@
project(llrender)
include(00-Common)
+include(FindOpenGL)
include(FreeType)
include(LLCommon)
include(LLImage)
@@ -89,3 +90,9 @@ else (SERVER AND NOT WINDOWS AND NOT DARWIN)
)
endif (SERVER AND NOT WINDOWS AND NOT DARWIN)
add_library (llrender ${llrender_SOURCE_FILES})
+# Libraries on which this library depends, needed for Linux builds
+# Sort by high-level to low-level
+target_link_libraries(llrender
+ llimage
+ ${FREETYPE_LIBRARIES}
+ ${OPENGL_LIBRARIES})