summaryrefslogtreecommitdiff
path: root/indra/llrender/CMakeLists.txt
diff options
context:
space:
mode:
authorJames Cook <james@lindenlab.com>2009-04-17 20:39:07 +0000
committerJames Cook <james@lindenlab.com>2009-04-17 20:39:07 +0000
commit57b47705d7a4a2927ac7329bd2b5b37c1c1c5115 (patch)
treeaf98d6cbc7b5918ee8bd2afda1ff8487cef603d7 /indra/llrender/CMakeLists.txt
parentb01c75cb423f07a3d3354f8bd62f265f80062b3b (diff)
Build system fixes for library-library dependencies, ported from skinning-7. OK by CG.
svn merge -r117623:117624 svn+ssh://svn.lindenlab.com/svn/linden/branches/skinning/skinning-7
Diffstat (limited to 'indra/llrender/CMakeLists.txt')
-rw-r--r--indra/llrender/CMakeLists.txt7
1 files changed, 7 insertions, 0 deletions
diff --git a/indra/llrender/CMakeLists.txt b/indra/llrender/CMakeLists.txt
index 0bdb55f9d0..0bb835970f 100644
--- a/indra/llrender/CMakeLists.txt
+++ b/indra/llrender/CMakeLists.txt
@@ -3,6 +3,7 @@
project(llrender)
include(00-Common)
+include(FindOpenGL)
include(FreeType)
include(LLCommon)
include(LLImage)
@@ -89,3 +90,9 @@ else (SERVER AND NOT WINDOWS AND NOT DARWIN)
)
endif (SERVER AND NOT WINDOWS AND NOT DARWIN)
add_library (llrender ${llrender_SOURCE_FILES})
+# Libraries on which this library depends, needed for Linux builds
+# Sort by high-level to low-level
+target_link_libraries(llrender
+ llimage
+ ${FREETYPE_LIBRARIES}
+ ${OPENGL_LIBRARIES})