summaryrefslogtreecommitdiff
path: root/indra/llplugin/CMakeLists.txt
diff options
context:
space:
mode:
authorNat Goodspeed <nat@lindenlab.com>2016-12-01 08:50:10 -0500
committerNat Goodspeed <nat@lindenlab.com>2016-12-01 08:50:10 -0500
commit8a461c00f4eb64027e4d81c081d6b7aa6d680d6e (patch)
tree078042e4363b64e6259bdb529bceaa7e1c26977e /indra/llplugin/CMakeLists.txt
parent68d98acb920a49880662db0d20ccdf52edbc0151 (diff)
DRTVWR-418: Until we figure out how to say FIXED:NO to linker, don't.
The present CMake logic wants to pass FIXED:NO to the linker for 64-bit builds, which on the face of it seems like a Good Thing: it permits code to be relocated in memory, preventing collisions if two libraries happen to want to load into overlapping address ranges. However the way it's being specified is wrong and harmful. Passing /FIXED:NO to the compiler command line engages /FI (Forced Include!) of a nonexistent file XED:NO -- producing lots of baffling fatal compile errors. Thanks Callum for diagnosing this!
Diffstat (limited to 'indra/llplugin/CMakeLists.txt')
-rw-r--r--indra/llplugin/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/indra/llplugin/CMakeLists.txt b/indra/llplugin/CMakeLists.txt
index 22f3b24dc5..2cdea67723 100644
--- a/indra/llplugin/CMakeLists.txt
+++ b/indra/llplugin/CMakeLists.txt
@@ -58,7 +58,7 @@ set_source_files_properties(${llplugin_HEADER_FILES}
if(NOT ADDRESS_SIZE EQUAL 32)
if(WINDOWS)
- add_definitions(/FIXED:NO)
+ ##add_definitions(/FIXED:NO)
else(WINDOWS) # not windows therefore gcc LINUX and DARWIN
add_definitions(-fPIC)
endif(WINDOWS)