summaryrefslogtreecommitdiff
path: root/indra/llplugin/CMakeLists.txt
diff options
context:
space:
mode:
authorDave SIMmONs <simon@lindenlab.com>2010-11-05 13:30:20 -0700
committerDave SIMmONs <simon@lindenlab.com>2010-11-05 13:30:20 -0700
commit447dc782fd4d490387fd98e9fb41135038512767 (patch)
treeb7875f5dd54d4068d777adbe90a3dd36b99a38eb /indra/llplugin/CMakeLists.txt
parentd5d4a065275d1db1093111222f29942ee171f81c (diff)
parent124a59263184391b0b4ec418c532b7a715e9b5a3 (diff)
Merge latest from lindenlab/viewer-development
Diffstat (limited to 'indra/llplugin/CMakeLists.txt')
-rw-r--r--indra/llplugin/CMakeLists.txt8
1 files changed, 8 insertions, 0 deletions
diff --git a/indra/llplugin/CMakeLists.txt b/indra/llplugin/CMakeLists.txt
index fdd510b389..d3a73058c4 100644
--- a/indra/llplugin/CMakeLists.txt
+++ b/indra/llplugin/CMakeLists.txt
@@ -51,6 +51,14 @@ set(llplugin_HEADER_FILES
set_source_files_properties(${llplugin_HEADER_FILES}
PROPERTIES HEADER_FILE_ONLY TRUE)
+if(NOT WORD_SIZE EQUAL 32)
+ if(WINDOWS)
+ add_definitions(/FIXED:NO)
+ else(WINDOWS) # not windows therefore gcc LINUX and DARWIN
+ add_definitions(-fPIC)
+ endif(WINDOWS)
+endif(NOT WORD_SIZE EQUAL 32)
+
list(APPEND llplugin_SOURCE_FILES ${llplugin_HEADER_FILES})
add_library (llplugin ${llplugin_SOURCE_FILES})