summaryrefslogtreecommitdiff
path: root/indra/llplugin/CMakeLists.txt
diff options
context:
space:
mode:
authorMike Antipov <mantipov@productengine.com>2010-04-01 12:28:08 +0300
committerMike Antipov <mantipov@productengine.com>2010-04-01 12:28:08 +0300
commit25976eb3da84cfa23ec6db779f830971ce8665e3 (patch)
tree2975019de434ebe9fc4f4ffbd92d56a21b3d8bf1 /indra/llplugin/CMakeLists.txt
parent7f38ea147466b6d045c90d710402b2ac321dbfd9 (diff)
parent68870a1f59c11a173353698b994f4540b214d57f (diff)
Merge from default branch
--HG-- branch : product-engine
Diffstat (limited to 'indra/llplugin/CMakeLists.txt')
-rw-r--r--indra/llplugin/CMakeLists.txt17
1 files changed, 17 insertions, 0 deletions
diff --git a/indra/llplugin/CMakeLists.txt b/indra/llplugin/CMakeLists.txt
index def9fcbeae..441becbae0 100644
--- a/indra/llplugin/CMakeLists.txt
+++ b/indra/llplugin/CMakeLists.txt
@@ -3,6 +3,7 @@
project(llplugin)
include(00-Common)
+include(CURL)
include(LLCommon)
include(LLImage)
include(LLMath)
@@ -55,3 +56,19 @@ list(APPEND llplugin_SOURCE_FILES ${llplugin_HEADER_FILES})
add_library (llplugin ${llplugin_SOURCE_FILES})
add_subdirectory(slplugin)
+
+# Add tests
+include(LLAddBuildTest)
+# UNIT TESTS
+SET(llplugin_TEST_SOURCE_FILES
+ llplugincookiestore.cpp
+ )
+
+# llplugincookiestore has a dependency on curl, so we need to link the curl library into the test.
+set_source_files_properties(
+ llplugincookiestore.cpp
+ PROPERTIES
+ LL_TEST_ADDITIONAL_LIBRARIES "${CURL_LIBRARIES}"
+ )
+
+LL_ADD_PROJECT_UNIT_TESTS(llplugin "${llplugin_TEST_SOURCE_FILES}")