summaryrefslogtreecommitdiff
path: root/indra/llmessage/CMakeLists.txt
diff options
context:
space:
mode:
authorNicky <nicky.dasmijn@gmail.com>2022-04-16 15:29:02 +0200
committerNicky <nicky.dasmijn@gmail.com>2022-04-16 15:29:02 +0200
commitbb85651d987a6cb969de7dd7c2b130411de6203c (patch)
treed143b3b23331469170515726baa8a76af60135dd /indra/llmessage/CMakeLists.txt
parentc8eb53859fb9b9f59d5ce8ef67f4011e95e34a9a (diff)
Create a new target ll::oslibrary to link against libs specific to the OS compiled on.
This gets rid of the a few OS specific set and uses variables (which some even seemed mostly duplicate like WINDOWS_LIBRARIES ans UI_LIBRARIES) and it also solves the problem of having them to tack on every target, as of no they come as a transitive dependency from llcommon
Diffstat (limited to 'indra/llmessage/CMakeLists.txt')
-rw-r--r--indra/llmessage/CMakeLists.txt17
1 files changed, 2 insertions, 15 deletions
diff --git a/indra/llmessage/CMakeLists.txt b/indra/llmessage/CMakeLists.txt
index 5f48ea60dc..20435d991a 100644
--- a/indra/llmessage/CMakeLists.txt
+++ b/indra/llmessage/CMakeLists.txt
@@ -220,27 +220,14 @@ if (LL_TESTS)
LL_ADD_PROJECT_UNIT_TESTS(llmessage "${llmessage_TEST_SOURCE_FILES}")
# set(TEST_DEBUG on)
-
-if (LINUX)
- set(test_libs
- ${WINDOWS_LIBRARIES}
- llfilesystem
- llmath
- llcorehttp
- llmessage
- llcommon
- rt
- )
-else (LINUX)
+
set(test_libs
- ${WINDOWS_LIBRARIES}
llfilesystem
llmath
llcorehttp
llmessage
llcommon
- )
-endif(LINUX)
+ )
#LL_ADD_INTEGRATION_TEST(llavatarnamecache "" "${test_libs}")
LL_ADD_INTEGRATION_TEST(llhost "" "${test_libs}")