summaryrefslogtreecommitdiff
path: root/indra/llmessage/CMakeLists.txt
diff options
context:
space:
mode:
authorBryan O'Sullivan <bos@lindenlab.com>2008-06-02 21:14:31 +0000
committerBryan O'Sullivan <bos@lindenlab.com>2008-06-02 21:14:31 +0000
commit9db949eec327df4173fde3de934a87bedb0db13c (patch)
treeaeffa0f0e68b1d2ceb74d460cbbd22652c9cd159 /indra/llmessage/CMakeLists.txt
parent419e13d0acaabf5e1e02e9b64a07648bce822b2f (diff)
svn merge -r88066:88786 svn+ssh://svn.lindenlab.com/svn/linden/branches/cmake-9-merge
dataserver-is-deprecated for-fucks-sake-whats-with-these-commit-markers
Diffstat (limited to 'indra/llmessage/CMakeLists.txt')
-rw-r--r--indra/llmessage/CMakeLists.txt191
1 files changed, 191 insertions, 0 deletions
diff --git a/indra/llmessage/CMakeLists.txt b/indra/llmessage/CMakeLists.txt
new file mode 100644
index 0000000000..ba17265a66
--- /dev/null
+++ b/indra/llmessage/CMakeLists.txt
@@ -0,0 +1,191 @@
+# -*- cmake -*-
+
+project(llmessage)
+
+include(00-Common)
+include(LLCommon)
+include(LLMath)
+include(LLMessage)
+include(LLVFS)
+
+include_directories (${CMAKE_CURRENT_SOURCE_DIR})
+
+include_directories(
+ ${LLCOMMON_INCLUDE_DIRS}
+ ${LLMATH_INCLUDE_DIRS}
+ ${LLMESSAGE_INCLUDE_DIRS}
+ ${LLVFS_INCLUDE_DIRS}
+ )
+
+set(llmessage_SOURCE_FILES
+ llares.cpp
+ llassetstorage.cpp
+ llblowfishcipher.cpp
+ llbuffer.cpp
+ llbufferstream.cpp
+ llcachename.cpp
+ llchainio.cpp
+ llcircuit.cpp
+ llclassifiedflags.cpp
+ llcurl.cpp
+ lldatapacker.cpp
+ lldispatcher.cpp
+ llfiltersd2xmlrpc.cpp
+ llhost.cpp
+ llhttpassetstorage.cpp
+ llhttpclient.cpp
+ llhttpnode.cpp
+ llhttpsender.cpp
+ llinstantmessage.cpp
+ lliobuffer.cpp
+ lliohttpserver.cpp
+ lliopipe.cpp
+ lliosocket.cpp
+ llioutil.cpp
+ llmail.cpp
+ llmessagebuilder.cpp
+ llmessageconfig.cpp
+ llmessagereader.cpp
+ llmessagetemplate.cpp
+ llmessagetemplateparser.cpp
+ llmessagethrottle.cpp
+ llmime.cpp
+ llnamevalue.cpp
+ llnullcipher.cpp
+ llpacketack.cpp
+ llpacketbuffer.cpp
+ llpacketring.cpp
+ llpartdata.cpp
+ llpumpio.cpp
+ llsdappservices.cpp
+ llsdhttpserver.cpp
+ llsdmessagebuilder.cpp
+ llsdmessagereader.cpp
+ llsdrpcclient.cpp
+ llsdrpcserver.cpp
+ llservicebuilder.cpp
+ llservice.cpp
+ lltemplatemessagebuilder.cpp
+ lltemplatemessagereader.cpp
+ llthrottle.cpp
+ lltransfermanager.cpp
+ lltransfersourceasset.cpp
+ lltransfersourcefile.cpp
+ lltransfertargetfile.cpp
+ lltransfertargetvfile.cpp
+ llurlrequest.cpp
+ lluseroperation.cpp
+ llxfer.cpp
+ llxfer_file.cpp
+ llxfermanager.cpp
+ llxfer_mem.cpp
+ llxfer_vfile.cpp
+ llxorcipher.cpp
+ message.cpp
+ message_prehash.cpp
+ message_string_table.cpp
+ net.cpp
+ network.cpp
+ partsyspacket.cpp
+ patch_code.cpp
+ patch_dct.cpp
+ patch_idct.cpp
+ )
+
+set(llmessage_HEADER_FILES
+ CMakeLists.txt
+
+ llares.h
+ llassetstorage.h
+ llblowfishcipher.h
+ llbuffer.h
+ llbufferstream.h
+ llcachename.h
+ llchainio.h
+ llcipher.h
+ llcircuit.h
+ llclassifiedflags.h
+ llcurl.h
+ lldatapacker.h
+ lldbstrings.h
+ lldispatcher.h
+ lleventflags.h
+ llfiltersd2xmlrpc.h
+ llfollowcamparams.h
+ llhost.h
+ llhttpassetstorage.h
+ llhttpclient.h
+ llhttpnode.h
+ llhttpsender.h
+ llinstantmessage.h
+ llinvite.h
+ lliobuffer.h
+ lliohttpserver.h
+ lliopipe.h
+ lliosocket.h
+ llioutil.h
+ llloginflags.h
+ llmail.h
+ llmessagebuilder.h
+ llmessageconfig.h
+ llmessagereader.h
+ llmessagetemplate.h
+ llmessagetemplateparser.h
+ llmessagethrottle.h
+ llmime.h
+ llmsgvariabletype.h
+ llnamevalue.h
+ llnullcipher.h
+ llpacketack.h
+ llpacketbuffer.h
+ llpacketring.h
+ llpartdata.h
+ llpumpio.h
+ llqueryflags.h
+ llregionflags.h
+ llregionhandle.h
+ llsdappservices.h
+ llsdhttpserver.h
+ llsdmessagebuilder.h
+ llsdmessagereader.h
+ llsdrpcclient.h
+ llsdrpcserver.h
+ llservice.h
+ llservicebuilder.h
+ lltaskname.h
+ llteleportflags.h
+ lltemplatemessagebuilder.h
+ lltemplatemessagereader.h
+ llthrottle.h
+ lltransfermanager.h
+ lltransfersourceasset.h
+ lltransfersourcefile.h
+ lltransfertargetfile.h
+ lltransfertargetvfile.h
+ llurlrequest.h
+ lluseroperation.h
+ llvehicleparams.h
+ llxfer.h
+ llxfermanager.h
+ llxfer_file.h
+ llxfer_mem.h
+ llxfer_vfile.h
+ llxorcipher.h
+ machine.h
+ mean_collision_data.h
+ message.h
+ message_prehash.h
+ net.h
+ network.h
+ partsyspacket.h
+ patch_code.h
+ patch_dct.h
+ sound_ids.h
+ )
+
+set_source_files_properties(${llmessage_HEADER_FILES}
+ PROPERTIES HEADER_FILE_ONLY TRUE)
+
+list(APPEND llmessage_SOURCE_FILES ${llmessage_HEADER_FILES})
+
+add_library (llmessage ${llmessage_SOURCE_FILES})