summaryrefslogtreecommitdiff
path: root/indra/llmessage/CMakeLists.txt
diff options
context:
space:
mode:
authorBryan O'Sullivan <bos@lindenlab.com>2008-08-29 22:16:44 +0000
committerBryan O'Sullivan <bos@lindenlab.com>2008-08-29 22:16:44 +0000
commit818535576c00847aef3c9e60142b5d2afa50d897 (patch)
tree8fd1298c5a78d10b96405c95e46d52ee2e8c27ce /indra/llmessage/CMakeLists.txt
parent1496c3d0eee43223ad9714b06ee94e334c730731 (diff)
Switch more libraries over to target_link_libraries
Diffstat (limited to 'indra/llmessage/CMakeLists.txt')
-rw-r--r--indra/llmessage/CMakeLists.txt8
1 files changed, 8 insertions, 0 deletions
diff --git a/indra/llmessage/CMakeLists.txt b/indra/llmessage/CMakeLists.txt
index ba17265a66..fd22de9399 100644
--- a/indra/llmessage/CMakeLists.txt
+++ b/indra/llmessage/CMakeLists.txt
@@ -189,3 +189,11 @@ set_source_files_properties(${llmessage_HEADER_FILES}
list(APPEND llmessage_SOURCE_FILES ${llmessage_HEADER_FILES})
add_library (llmessage ${llmessage_SOURCE_FILES})
+target_link_libraries(
+ llmessage
+ ${CURL_LIBRARIES}
+ ${CARES_LIBRARIES}
+ ${OPENSSL_LIBRARIES}
+ ${CRYPTO_LIBRARIES}
+ ${XMLRPCEPI_LIBRARIES}
+ )