summaryrefslogtreecommitdiff
path: root/indra/llmath/CMakeLists.txt
diff options
context:
space:
mode:
authorMartin Reddy <lynx@lindenlab.com>2009-07-15 16:02:31 +0000
committerMartin Reddy <lynx@lindenlab.com>2009-07-15 16:02:31 +0000
commit28c9537398434a75a0a46c401754b1048b4d91e1 (patch)
tree05b1c2a3bb7cd69822491f989aebd409cc9f9e79 /indra/llmath/CMakeLists.txt
parent7cdaba233244746ccfe40cb8e5542ac63fc1927f (diff)
DEV-35500: Write new llmath unit tests
- Added unit tests for LLRect and LLBBoxLocal in indra/test - Moved newview/LLBBox to llmath, and added unit tests for it - Removed methods in llbboxlocal.h and llbbox.h that were not actually implemented (declared in .h, but not defined in cpp) Reviewed by babbage.
Diffstat (limited to 'indra/llmath/CMakeLists.txt')
-rw-r--r--indra/llmath/CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/indra/llmath/CMakeLists.txt b/indra/llmath/CMakeLists.txt
index 075d3b3af0..d287a5063a 100644
--- a/indra/llmath/CMakeLists.txt
+++ b/indra/llmath/CMakeLists.txt
@@ -10,6 +10,7 @@ include_directories(
)
set(llmath_SOURCE_FILES
+ llbbox.cpp
llbboxlocal.cpp
llcamera.cpp
llcoordframe.cpp
@@ -39,6 +40,7 @@ set(llmath_HEADER_FILES
camera.h
coordframe.h
+ llbbox.h
llbboxlocal.h
llcamera.h
llcoord.h