summaryrefslogtreecommitdiff
path: root/indra/llimage/CMakeLists.txt
diff options
context:
space:
mode:
authorBryan O'Sullivan <bos@lindenlab.com>2008-06-02 21:14:31 +0000
committerBryan O'Sullivan <bos@lindenlab.com>2008-06-02 21:14:31 +0000
commit9db949eec327df4173fde3de934a87bedb0db13c (patch)
treeaeffa0f0e68b1d2ceb74d460cbbd22652c9cd159 /indra/llimage/CMakeLists.txt
parent419e13d0acaabf5e1e02e9b64a07648bce822b2f (diff)
svn merge -r88066:88786 svn+ssh://svn.lindenlab.com/svn/linden/branches/cmake-9-merge
dataserver-is-deprecated for-fucks-sake-whats-with-these-commit-markers
Diffstat (limited to 'indra/llimage/CMakeLists.txt')
-rw-r--r--indra/llimage/CMakeLists.txt50
1 files changed, 50 insertions, 0 deletions
diff --git a/indra/llimage/CMakeLists.txt b/indra/llimage/CMakeLists.txt
new file mode 100644
index 0000000000..5593b4a0cb
--- /dev/null
+++ b/indra/llimage/CMakeLists.txt
@@ -0,0 +1,50 @@
+# -*- cmake -*-
+
+project(llimage)
+
+include(00-Common)
+include(LLCommon)
+include(LLImage)
+include(LLMath)
+include(LLVFS)
+
+include_directories(
+ ${LLCOMMON_INCLUDE_DIRS}
+ ${LLMATH_INCLUDE_DIRS}
+ ${LLVFS_INCLUDE_DIRS}
+ ${PNG_INCLUDE_DIRS}
+ )
+
+set(llimage_SOURCE_FILES
+ llimagebmp.cpp
+ llimage.cpp
+ llimagedxt.cpp
+ llimagej2c.cpp
+ llimagejpeg.cpp
+ llimagepng.cpp
+ llimagetga.cpp
+ llimageworker.cpp
+ llpngwrapper.cpp
+ )
+
+set(llimage_HEADER_FILES
+ CMakeLists.txt
+
+ llimage.h
+ llimagebmp.h
+ llimagedxt.h
+ llimagej2c.h
+ llimagejpeg.h
+ llimagepng.h
+ llimagetga.h
+ llimageworker.h
+ llmapimagetype.h
+ llpngwrapper.h
+ )
+
+set_source_files_properties(${llimage_HEADER_FILES}
+ PROPERTIES HEADER_FILE_ONLY TRUE)
+
+list(APPEND llimage_SOURCE_FILES ${llimage_HEADER_FILES})
+
+add_library (llimage ${llimage_SOURCE_FILES})