summaryrefslogtreecommitdiff
path: root/indra/llcorehttp/CMakeLists.txt
diff options
context:
space:
mode:
authorNicky <nicky.dasmijn@gmail.com>2022-04-17 18:04:57 +0200
committerNicky <nicky.dasmijn@gmail.com>2022-04-17 18:04:57 +0200
commite0cf0cdfd49e5a946dcd202a083fb23f01e4f1fe (patch)
tree52edc824cb295c92f668b7912e7fbcbf272132aa /indra/llcorehttp/CMakeLists.txt
parent6d0bba9c03da0d8aca5e88fcb9289cb2f89f3467 (diff)
Switch to target_include_directories
All 3Ps include dirs are treated as SYSTEM, this will stop compilers stop emitting warnings from those files and greatly helps having high warning levels and not being swamped by warnings that come from external libraries.
Diffstat (limited to 'indra/llcorehttp/CMakeLists.txt')
-rw-r--r--indra/llcorehttp/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/indra/llcorehttp/CMakeLists.txt b/indra/llcorehttp/CMakeLists.txt
index e2bd9ae5b8..f93104b321 100644
--- a/indra/llcorehttp/CMakeLists.txt
+++ b/indra/llcorehttp/CMakeLists.txt
@@ -91,7 +91,7 @@ target_link_libraries(
ll::openssl
ll::nghttp2
)
-set_target_include_dirs( llcorehttp ${CMAKE_CURRENT_SOURCE_DIR})
+target_include_directories( llcorehttp INTERFACE ${CMAKE_CURRENT_SOURCE_DIR})
# tests