summaryrefslogtreecommitdiff
path: root/indra/llcorehttp/CMakeLists.txt
diff options
context:
space:
mode:
authorNat Goodspeed <nat@lindenlab.com>2015-07-09 21:42:34 -0400
committerNat Goodspeed <nat@lindenlab.com>2015-07-09 21:42:34 -0400
commit657944cda7228ba824239d94b270160ac0460934 (patch)
tree0e479f811eb737ccdd7e728f687452e0eb141029 /indra/llcorehttp/CMakeLists.txt
parent4aa64b99dbe6cafdccf0c25501feaef5ba3445c4 (diff)
Suppress http_proxy env var for llcorehttp integration test.
Sometimes it can be useful to have http_proxy set in the environment, but if we leave it set while INTEGRATION_TEST_llcorehttp is running, the test hangs. Suppress that variable for that integration test.
Diffstat (limited to 'indra/llcorehttp/CMakeLists.txt')
-rwxr-xr-xindra/llcorehttp/CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/indra/llcorehttp/CMakeLists.txt b/indra/llcorehttp/CMakeLists.txt
index a0b1ea13b1..9631e960c5 100755
--- a/indra/llcorehttp/CMakeLists.txt
+++ b/indra/llcorehttp/CMakeLists.txt
@@ -134,9 +134,13 @@ if (LL_TESTS)
${BOOST_THREAD_LIBRARY}
)
+ # If http_proxy is in the current environment (e.g. to fetch s3-proxy
+ # autobuild packages), suppress it for this integration test: it screws up
+ # the tests.
LL_ADD_INTEGRATION_TEST(llcorehttp
"${llcorehttp_TEST_SOURCE_FILES}"
"${test_libs}"
+ "-Dhttp_proxy"
${PYTHON_EXECUTABLE}
"${CMAKE_CURRENT_SOURCE_DIR}/tests/test_llcorehttp_peer.py"
)