summaryrefslogtreecommitdiff
path: root/indra/llcommon/CMakeLists.txt
diff options
context:
space:
mode:
authorNat Goodspeed <nat@lindenlab.com>2024-09-04 14:07:26 -0400
committerNat Goodspeed <nat@lindenlab.com>2024-09-04 14:07:26 -0400
commitea24ac899ca28a587be0e187b77873a25d08a556 (patch)
tree4645577b8c1e3b60079a67c98dd95c9a03a7c8c6 /indra/llcommon/CMakeLists.txt
parent03d7f2b84daf9ab991de6cad7d6149abda1ef716 (diff)
Extract coroutine-aware synchronization primitives to new header.
Changes on new main and changes on Lua project branch combined into a header circularity. Resolved by hoisting coroutine-aware synchronization primitives out to a new llcoromutex.h file in the `llcoro` namespace, rather than being literally members of the `LLCoros` class. But retained `using` declarations in `LLCoros` for backwards compatibility.
Diffstat (limited to 'indra/llcommon/CMakeLists.txt')
-rw-r--r--indra/llcommon/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/indra/llcommon/CMakeLists.txt b/indra/llcommon/CMakeLists.txt
index f893702118..22cc22abba 100644
--- a/indra/llcommon/CMakeLists.txt
+++ b/indra/llcommon/CMakeLists.txt
@@ -153,6 +153,7 @@ set(llcommon_HEADER_FILES
llcommonutils.h
llcond.h
llcoros.h
+ llcoromutex.h
llcrc.h
llcriticaldamp.h
lldate.h