summaryrefslogtreecommitdiff
path: root/indra/llcommon/CMakeLists.txt
diff options
context:
space:
mode:
authorErik Kundiman <erik@megapahit.org>2023-07-12 10:20:18 +0800
committerErik Kundiman <erik@megapahit.org>2023-07-19 10:56:21 +0800
commitb0f295ec2a2fd448bb248befb5b57b26b6144332 (patch)
tree3370d36ce2d2a1f6044b9b5c6eba4806b27d5deb /indra/llcommon/CMakeLists.txt
parent088b508ddcb3c7934c400ff545a08d32e7ce1a40 (diff)
Disable copy 3rd party libs when using system libs
Diffstat (limited to 'indra/llcommon/CMakeLists.txt')
-rw-r--r--indra/llcommon/CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/indra/llcommon/CMakeLists.txt b/indra/llcommon/CMakeLists.txt
index ef4899978e..c58956bd36 100644
--- a/indra/llcommon/CMakeLists.txt
+++ b/indra/llcommon/CMakeLists.txt
@@ -9,7 +9,9 @@ include(Linking)
include(Boost)
include(LLSharedLibs)
include(JsonCpp)
+if (USE_AUTOBUILD_3P OR USE_CONAN)
include(Copy3rdPartyLibs)
+endif ()
include(ZLIBNG)
include(URIPARSER)
include(Tracy)
@@ -277,7 +279,9 @@ target_link_libraries(
target_include_directories(llcommon INTERFACE ${CMAKE_CURRENT_SOURCE_DIR})
target_include_directories(llcommon PRIVATE ${CMAKE_CURRENT_SOURCE_DIR})
+if (USE_AUTOBUILD_3P OR USE_CONAN)
add_dependencies(llcommon stage_third_party_libs)
+endif ()
if (LL_TESTS)
include(LLAddBuildTest)