summaryrefslogtreecommitdiff
path: root/indra/llcommon/CMakeLists.txt
diff options
context:
space:
mode:
authorNat Goodspeed <nat@lindenlab.com>2018-06-14 11:31:17 -0400
committerNat Goodspeed <nat@lindenlab.com>2018-06-14 11:31:17 -0400
commitac2604a039bb9477cf9102dfccd77619a6061d7a (patch)
tree19184971229ddee034f38f3299e1dc450d2292ba /indra/llcommon/CMakeLists.txt
parentab9a3db37f132c4d2d2b28005e28b2c0a347af98 (diff)
SL-821: Avoid Breakpad (and signal handling in general) for BugSplat.
Pass LL_BUGSPLAT into llapp.cpp compile to be able to detect that.
Diffstat (limited to 'indra/llcommon/CMakeLists.txt')
-rw-r--r--indra/llcommon/CMakeLists.txt5
1 files changed, 5 insertions, 0 deletions
diff --git a/indra/llcommon/CMakeLists.txt b/indra/llcommon/CMakeLists.txt
index d9eb13d65a..8977acb873 100644
--- a/indra/llcommon/CMakeLists.txt
+++ b/indra/llcommon/CMakeLists.txt
@@ -255,6 +255,11 @@ set(llcommon_HEADER_FILES
set_source_files_properties(${llcommon_HEADER_FILES}
PROPERTIES HEADER_FILE_ONLY TRUE)
+if (DEFINED ENV{BUGSPLAT_DB})
+ set_source_files_properties(llapp.cpp
+ PROPERTIES COMPILE_DEFINITIONS "LL_BUGSPLAT")
+endif (DEFINED ENV{BUGSPLAT_DB})
+
list(APPEND llcommon_SOURCE_FILES ${llcommon_HEADER_FILES})
if(LLCOMMON_LINK_SHARED)