summaryrefslogtreecommitdiff
path: root/indra/llcommon/CMakeLists.txt
diff options
context:
space:
mode:
authorNat Goodspeed <nat@lindenlab.com>2024-08-12 15:58:03 -0400
committerNat Goodspeed <nat@lindenlab.com>2024-08-12 15:58:03 -0400
commita596c1ad2864d639bbab13e7f13fd9f029cf5d93 (patch)
tree187fe226d7f5f9be5baad36c5cde6986e8a7ba26 /indra/llcommon/CMakeLists.txt
parent926a32aa0a9518fe7f19d0c63b30b12a66469f2d (diff)
Add Throttle and LogThrottle classes to manage throttled APIs.
Diffstat (limited to 'indra/llcommon/CMakeLists.txt')
-rw-r--r--indra/llcommon/CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/indra/llcommon/CMakeLists.txt b/indra/llcommon/CMakeLists.txt
index 20670d7ebe..4c4a676531 100644
--- a/indra/llcommon/CMakeLists.txt
+++ b/indra/llcommon/CMakeLists.txt
@@ -112,6 +112,7 @@ set(llcommon_SOURCE_FILES
lua_function.cpp
lualistener.cpp
threadpool.cpp
+ throttle.cpp
u64.cpp
workqueue.cpp
StackWalker.cpp
@@ -263,6 +264,7 @@ set(llcommon_HEADER_FILES
threadpool.h
threadpool_fwd.h
threadsafeschedule.h
+ throttle.h
timer.h
tuple.h
u64.h