summaryrefslogtreecommitdiff
path: root/indra/llcommon/CMakeLists.txt
diff options
context:
space:
mode:
authorNat Goodspeed <nat@lindenlab.com>2009-08-28 19:13:13 +0000
committerNat Goodspeed <nat@lindenlab.com>2009-08-28 19:13:13 +0000
commit76aa6cc293b32681bb3350bda2be90a97c0acd0f (patch)
tree42544db244ae956b877b553333d82fac93fe09d7 /indra/llcommon/CMakeLists.txt
parenteda3831041a176ae11116bd0c33077d121dc62e2 (diff)
DEV-38596: Introduce Mani's LL_ADD_INTEGRATION_TEST macro.
LL_ADD_INTEGRATION_TEST supports tests that may require linking against one or more Linden libraries, or that should be executed with a wrapper script. Use this to test lllazy.cpp, llsdmessage.cpp and llcapabilitylistener.cpp.
Diffstat (limited to 'indra/llcommon/CMakeLists.txt')
-rw-r--r--indra/llcommon/CMakeLists.txt5
1 files changed, 4 insertions, 1 deletions
diff --git a/indra/llcommon/CMakeLists.txt b/indra/llcommon/CMakeLists.txt
index 4b24a7ad2b..9f1b0b48d8 100644
--- a/indra/llcommon/CMakeLists.txt
+++ b/indra/llcommon/CMakeLists.txt
@@ -239,8 +239,11 @@ SET(llcommon_TEST_SOURCE_FILES
)
LL_ADD_PROJECT_UNIT_TESTS(llcommon "${llcommon_TEST_SOURCE_FILES}")
+#set(TEST_DEBUG on)
+set(test_libs llcommon ${LLCOMMON_LIBRARIES} ${WINDOWS_LIBRARIES})
+LL_ADD_INTEGRATION_TEST(lllazy lllazy.cpp "${test_libs}")
+
# *TODO - reenable these once tcmalloc libs no longer break the build.
#ADD_BUILD_TEST(llallocator llcommon)
#ADD_BUILD_TEST(llallocator_heap_profile llcommon)
#ADD_BUILD_TEST(llmemtype llcommon)
-