summaryrefslogtreecommitdiff
path: root/indra/llcommon/CMakeLists.txt
diff options
context:
space:
mode:
authorbrad kittenbrink <brad@lindenlab.com>2009-06-30 11:52:00 -0400
committerbrad kittenbrink <brad@lindenlab.com>2009-06-30 11:52:00 -0400
commit726ac3ed0f70900edbeeacece866a21ff90534d4 (patch)
tree4625fce9d0e7fa8a3da2fbfa59b4680b2a57c96d /indra/llcommon/CMakeLists.txt
parentdb7b4bb3f8905518b303e371d61fdc3aabd7b9be (diff)
Fixes to let llcommon build as a .dylib. It depends on PTH library.
Diffstat (limited to 'indra/llcommon/CMakeLists.txt')
-rw-r--r--indra/llcommon/CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/indra/llcommon/CMakeLists.txt b/indra/llcommon/CMakeLists.txt
index 4ba74ab837..06a295b410 100644
--- a/indra/llcommon/CMakeLists.txt
+++ b/indra/llcommon/CMakeLists.txt
@@ -7,11 +7,13 @@ include(LLAddBuildTest)
include(LLCommon)
include(Linking)
include(Boost)
+include (Pth)
include_directories(
${EXPAT_INCLUDE_DIRS}
${LLCOMMON_INCLUDE_DIRS}
${ZLIB_INCLUDE_DIRS}
+ ${PTH_INCLUDE_DIRS}
)
# add_executable(lltreeiterators lltreeiterators.cpp)
@@ -245,6 +247,7 @@ target_link_libraries(
${WINDOWS_LIBRARIES}
${BOOST_PROGRAM_OPTIONS_LIBRARY}
${BOOST_REGEX_LIBRARY}
+ ${PTH_LIBRARIES}
)
include(LLAddBuildTest)