summaryrefslogtreecommitdiff
path: root/indra/llcommon/CMakeLists.txt
diff options
context:
space:
mode:
authorNat Goodspeed <nat@lindenlab.com>2009-05-08 21:08:08 +0000
committerNat Goodspeed <nat@lindenlab.com>2009-05-08 21:08:08 +0000
commit3800c0df910c83e987184d541b868168fc2b5bec (patch)
tree91bcf4e13972ae02b9d6500c1d14de7bb8d37dc4 /indra/llcommon/CMakeLists.txt
parent5da967dc744f35d5270c7cb0b8b23b993ecda3e1 (diff)
svn merge -r114679:114681 svn+ssh://svn.lindenlab.com/svn/linden/branches/event-system/event-system-7 svn+ssh://svn.lindenlab.com/svn/linden/branches/event-system/event-system-8
Diffstat (limited to 'indra/llcommon/CMakeLists.txt')
-rw-r--r--indra/llcommon/CMakeLists.txt9
1 files changed, 9 insertions, 0 deletions
diff --git a/indra/llcommon/CMakeLists.txt b/indra/llcommon/CMakeLists.txt
index c4663cc145..694f3d5de8 100644
--- a/indra/llcommon/CMakeLists.txt
+++ b/indra/llcommon/CMakeLists.txt
@@ -3,6 +3,7 @@
project(llcommon)
include(00-Common)
+include(LLAddBuildTest)
include(LLCommon)
include(Boost)
@@ -28,9 +29,11 @@ set(llcommon_SOURCE_FILES
llcriticaldamp.cpp
llcursortypes.cpp
lldate.cpp
+ lldependencies.cpp
llerror.cpp
llerrorthread.cpp
llevent.cpp
+ llevents.cpp
llfasttimer.cpp
llfile.cpp
llfindlocale.cpp
@@ -103,6 +106,7 @@ set(llcommon_HEADER_FILES
lldarrayptr.h
lldate.h
lldefs.h
+ lldependencies.h
lldepthstack.h
lldlinked.h
lldoubledispatch.h
@@ -114,6 +118,7 @@ set(llcommon_HEADER_FILES
llerrorlegacy.h
llerrorthread.h
llevent.h
+ llevents.h
lleventemitter.h
llextendedstatus.h
llfasttimer.h
@@ -129,6 +134,7 @@ set(llcommon_HEADER_FILES
llindraconfigfile.h
llinstancetracker.h
llkeythrottle.h
+ lllazy.h
lllinkedqueue.h
llliveappconfig.h
lllivefile.h
@@ -194,6 +200,7 @@ set(llcommon_HEADER_FILES
stdenums.h
stdtypes.h
string_table.h
+ stringize.h
timer.h
timing.h
u64.h
@@ -214,3 +221,5 @@ target_link_libraries(
${BOOST_PROGRAM_OPTIONS_LIBRARY}
${BOOST_REGEX_LIBRARY}
)
+
+ADD_BUILD_TEST(lllazy llcommon)