summaryrefslogtreecommitdiff
path: root/indra/llcommon/CMakeLists.txt
diff options
context:
space:
mode:
authorpalmer@eniac54.lindenlab.com <palmer@eniac54.lindenlab.com>2009-07-30 18:52:34 -0700
committerpalmer@eniac54.lindenlab.com <palmer@eniac54.lindenlab.com>2009-07-30 18:52:34 -0700
commit1af41b3ba733938541d7cc92ae56dd883638e32f (patch)
tree34e20eebc9c5e28a58dfc7b45823f8156e1f2edf /indra/llcommon/CMakeLists.txt
parent1e1a38d5745a680c712be9bcc088a75f6eafa7da (diff)
Fixes to build on linux for DEV-35401.
Moves libllcommon.so to a staging dir for unit tests to work and gets rid of LL_COMMON_API in forward declarations
Diffstat (limited to 'indra/llcommon/CMakeLists.txt')
-rw-r--r--indra/llcommon/CMakeLists.txt15
1 files changed, 15 insertions, 0 deletions
diff --git a/indra/llcommon/CMakeLists.txt b/indra/llcommon/CMakeLists.txt
index c46e2583f1..2ecd4ee5d4 100644
--- a/indra/llcommon/CMakeLists.txt
+++ b/indra/llcommon/CMakeLists.txt
@@ -245,6 +245,20 @@ if(LLCOMMON_LINK_SHARED)
# Also this directory is shared with RunBuildTest.cmake, y'know, for the tests.
set_target_properties(llcommon PROPERTIES RUNTIME_OUTPUT_DIRECTORY ${SHARED_LIB_STAGING_DIR})
endif(SHARED_LIB_STAGING_DIR)
+
+ get_target_property(LLCOMMON_PATH llcommon LOCATION)
+ get_filename_component(LLCOMMON_FILE ${LLCOMMON_PATH} NAME)
+ add_custom_command(
+ TARGET llcommon POST_BUILD
+ COMMAND ${CMAKE_COMMAND}
+ ARGS
+ -E
+ copy_if_different
+ ${LLCOMMON_FILE}
+ ${SHARED_LIB_STAGING_DIR}/${CMAKE_CFG_INTDIR}/${LLCOMMON_FILE}
+ COMMENT "Copying llcommon to the staging folder."
+ )
+
else(LLCOMMON_LINK_SHARED)
add_library (llcommon ${llcommon_SOURCE_FILES})
endif(LLCOMMON_LINK_SHARED)
@@ -263,6 +277,7 @@ target_link_libraries(
add_dependencies(llcommon stage_third_party_libs)
+
include(LLAddBuildTest)
SET(llcommon_TEST_SOURCE_FILES
# WARNING: Please don't write tests against LLCommon or LLMath until this issue is resolved: https://jira.lindenlab.com/jira/browse/DEV-29456