summaryrefslogtreecommitdiff
path: root/indra/llcommon/CMakeLists.txt
diff options
context:
space:
mode:
authorBrad Kittenbrink <brad@lindenlab.com>2009-06-10 00:00:03 +0000
committerBrad Kittenbrink <brad@lindenlab.com>2009-06-10 00:00:03 +0000
commit050d2db0f805d799c59349253262b648aa8f70b2 (patch)
treedfc8e49391a461ca6c54cedcad0bb1c2b89979f9 /indra/llcommon/CMakeLists.txt
parent820d4a20d1b9c9a3e562b925ba59a6addcffa558 (diff)
Added LLAPRSockStream class and associated LLAPRSockStreambuf class for
DEV-31978 viewer event host socket module. reviewed by palmer+nat+mani.
Diffstat (limited to 'indra/llcommon/CMakeLists.txt')
-rw-r--r--indra/llcommon/CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/indra/llcommon/CMakeLists.txt b/indra/llcommon/CMakeLists.txt
index bbfadbb344..e920475f54 100644
--- a/indra/llcommon/CMakeLists.txt
+++ b/indra/llcommon/CMakeLists.txt
@@ -22,6 +22,7 @@ include_directories(
set(llcommon_SOURCE_FILES
llapp.cpp
llapr.cpp
+ llaprsockstream.cpp
llassettype.cpp
llbase32.cpp
llbase64.cpp
@@ -94,6 +95,7 @@ set(llcommon_HEADER_FILES
llagentconstants.h
llapp.h
llapr.h
+ llaprsockstream.h
llassettype.h
llassoclist.h
llavatarconstants.h
@@ -236,6 +238,7 @@ target_link_libraries(
${BOOST_REGEX_LIBRARY}
)
+ADD_BUILD_TEST(llaprsockstream llcommon)
ADD_BUILD_TEST(lllazy llcommon)
ADD_BUILD_TEST(lleventfilter llcommon)
ADD_BUILD_TEST(lleventcoro llcommon)