summaryrefslogtreecommitdiff
path: root/indra/llcharacter/CMakeLists.txt
diff options
context:
space:
mode:
authorCallum Prentice <callum@lindenlab.com>2021-03-09 14:26:24 -0800
committerCallum Prentice <callum@lindenlab.com>2021-03-09 14:26:24 -0800
commit519cbcecdf78e4dfc3adc465ae8cebed5df71647 (patch)
treeefa8e20856dbfc80e1ae44283cbd0139b828b1b2 /indra/llcharacter/CMakeLists.txt
parentada8ad1bc21665631f030c3194a567ea6f6a2a72 (diff)
parent88d837c16e768c5262073a7df965066d4bd8842c (diff)
Merge with master before reseting to revert (revert) and get back to D519 status
Diffstat (limited to 'indra/llcharacter/CMakeLists.txt')
-rw-r--r--indra/llcharacter/CMakeLists.txt18
1 files changed, 15 insertions, 3 deletions
diff --git a/indra/llcharacter/CMakeLists.txt b/indra/llcharacter/CMakeLists.txt
index d90ffb5543..a17a5b0aa6 100644
--- a/indra/llcharacter/CMakeLists.txt
+++ b/indra/llcharacter/CMakeLists.txt
@@ -6,14 +6,14 @@ include(00-Common)
include(LLCommon)
include(LLMath)
include(LLMessage)
-include(LLFileSystem)
+include(LLVFS)
include(LLXML)
include_directories(
${LLCOMMON_INCLUDE_DIRS}
${LLMATH_INCLUDE_DIRS}
${LLMESSAGE_INCLUDE_DIRS}
- ${LLFILESYSTEM_INCLUDE_DIRS}
+ ${LLVFS_INCLUDE_DIRS}
${LLXML_INCLUDE_DIRS}
)
include_directories(SYSTEM
@@ -85,6 +85,18 @@ target_link_libraries(
${LLCOMMON_LIBRARIES}
${LLMATH_LIBRARIES}
${LLMESSAGE_LIBRARIES}
- ${LLFILESYSTEM_LIBRARIES}
+ ${LLVFS_LIBRARIES}
${LLXML_LIBRARIES}
)
+
+
+# Add tests
+#if (LL_TESTS)
+# include(LLAddBuildTest)
+# # UNIT TESTS
+# SET(llcharacter_TEST_SOURCE_FILES
+# lljoint.cpp
+# )
+# LL_ADD_PROJECT_UNIT_TESTS(llcharacter "${llcharacter_TEST_SOURCE_FILES}")
+#endif (LL_TESTS)
+