summaryrefslogtreecommitdiff
path: root/indra/llappearance/CMakeLists.txt
diff options
context:
space:
mode:
authorDon Kjer <don@lindenlab.com>2012-09-13 10:25:48 +0000
committerDon Kjer <don@lindenlab.com>2012-09-13 10:25:48 +0000
commit8ba2b388769e245ec1b49b7d6d4b0372d684ff86 (patch)
treeb43b39372fe156aac4f70cd22456c7df8d1df101 /indra/llappearance/CMakeLists.txt
parent929b7e029513ecbb08c415e945c83ea09dc1b3eb (diff)
Fleshed out target_link_libraries dependencies between libraries. Appearance utility now reads avatar_lad.xml during stubbed out params processing.
Diffstat (limited to 'indra/llappearance/CMakeLists.txt')
-rw-r--r--indra/llappearance/CMakeLists.txt25
1 files changed, 12 insertions, 13 deletions
diff --git a/indra/llappearance/CMakeLists.txt b/indra/llappearance/CMakeLists.txt
index adce620372..c570f0c93b 100644
--- a/indra/llappearance/CMakeLists.txt
+++ b/indra/llappearance/CMakeLists.txt
@@ -4,37 +4,24 @@ project(llappearance)
include(00-Common)
include(LLCommon)
-include(LLAudio)
include(LLCharacter)
-include(LLCommon)
include(LLImage)
-include(LLImageJ2COJ)
include(LLInventory)
include(LLMath)
include(LLMessage)
-include(LLPhysicsExtensions)
-include(LLPlugin)
-include(LLPrimitive)
include(LLRender)
-include(LLUI)
include(LLVFS)
include(LLWindow)
include(LLXML)
include(Linking)
-include(LLKDU)
-include(ViewerMiscLibs)
-include(LLLogin)
include_directories(
${LLCOMMON_INCLUDE_DIRS}
${LLCHARACTER_INCLUDE_DIRS}
- ${LLPHYSICS_INCLUDE_DIRS}
${LLIMAGE_INCLUDE_DIRS}
- ${LLKDU_INCLUDE_DIRS}
${LLINVENTORY_INCLUDE_DIRS}
${LLMATH_INCLUDE_DIRS}
${LLRENDER_INCLUDE_DIRS}
- ${LLUI_INCLUDE_DIRS}
${LLVFS_INCLUDE_DIRS}
${LLWINDOW_INCLUDE_DIRS}
${LLXML_INCLUDE_DIRS}
@@ -90,6 +77,18 @@ list(APPEND llappearance_SOURCE_FILES ${llappearance_HEADER_FILES})
add_library (llappearance ${llappearance_SOURCE_FILES})
+target_link_libraries(llappearance
+ ${LLCHARACTER_LIBRARIES}
+ ${LLINVENTORY_LIBRARIES}
+ ${LLIMAGE_LIBRARIES}
+ ${LLRENDER_LIBRARIES}
+ ${LLVFS_LIBRARIES}
+ ${LLMATH_LIBRARIES}
+ ${LLXML_LIBRARIES}
+ ${LLMATH_LIBRARIES}
+ ${LLCOMMON_LIBRARIES}
+ )
+
#add unit tests
#if (LL_TESTS)
# INCLUDE(LLAddBuildTest)