summaryrefslogtreecommitdiff
path: root/indra/integration_tests/llimage_libtest/CMakeLists.txt
diff options
context:
space:
mode:
authorOz Linden <oz@lindenlab.com>2016-12-16 08:18:08 -0500
committerOz Linden <oz@lindenlab.com>2016-12-16 08:18:08 -0500
commit058ac4ba50acb8f2b1340136a69bfe52ad7be425 (patch)
tree56bd1e7e1ac869ca8eb9aba1e219aae2b03e732b /indra/integration_tests/llimage_libtest/CMakeLists.txt
parent274d549eab1c9964f91d639d7335d205a4273e7c (diff)
parent89cd49f60f87852d94b3c21ef70e3fa2ed990e51 (diff)
merge updates from nat
Diffstat (limited to 'indra/integration_tests/llimage_libtest/CMakeLists.txt')
-rw-r--r--indra/integration_tests/llimage_libtest/CMakeLists.txt10
1 files changed, 6 insertions, 4 deletions
diff --git a/indra/integration_tests/llimage_libtest/CMakeLists.txt b/indra/integration_tests/llimage_libtest/CMakeLists.txt
index 44384532cd..13cf1f7bde 100644
--- a/indra/integration_tests/llimage_libtest/CMakeLists.txt
+++ b/indra/integration_tests/llimage_libtest/CMakeLists.txt
@@ -115,10 +115,12 @@ if (DARWIN)
COMMAND ${CMAKE_COMMAND} -E copy ${AUTOBUILD_INSTALL_DIR}/lib/release/libexception_handler.dylib ${LLIMAGE_LIBTEST_DESTINATION_DIR}
DEPENDS ${AUTOBUILD_INSTALL_DIR}/lib/release/libexception_handler.dylib
)
- add_custom_command(TARGET llimage_libtest POST_BUILD
- COMMAND ${CMAKE_COMMAND} -E copy ${AUTOBUILD_INSTALL_DIR}/lib/release/libexpat.1.5.2.dylib ${LLIMAGE_LIBTEST_DESTINATION_DIR}
- DEPENDS ${AUTOBUILD_INSTALL_DIR}/lib/release/libexpat.1.5.2.dylib
- )
+ foreach(expat ${EXPAT_COPY})
+ add_custom_command(TARGET llimage_libtest POST_BUILD
+ COMMAND ${CMAKE_COMMAND} -E copy ${AUTOBUILD_INSTALL_DIR}/lib/release/${expat} ${LLIMAGE_LIBTEST_DESTINATION_DIR}
+ DEPENDS ${AUTOBUILD_INSTALL_DIR}/lib/release/${expat}
+ )
+ endforeach(expat)
endif (DARWIN)
if (WINDOWS)