summaryrefslogtreecommitdiff
path: root/indra/cmake/CMakeLists.txt
diff options
context:
space:
mode:
authorNat Goodspeed <nat@lindenlab.com>2009-09-08 12:03:32 -0400
committerNat Goodspeed <nat@lindenlab.com>2009-09-08 12:03:32 -0400
commitb9546a33e90df60e2d47735b4627de4eb97ba6b9 (patch)
tree7540fa5f858ed98229ec397f91e98c1c1ac72724 /indra/cmake/CMakeLists.txt
parent369f5ba524e7ad7760b2e367ad336d09d129733e (diff)
QAR-1619: Finish replacing RunBuildTest.cmake with run_build_test.py.
Because the details of RunBuildTest.cmake versus run_build_test.py had to be changed in so many different places, introduce LL_TEST_COMMAND CMake macro (in LLTestCommand.cmake) to encapsulate construction of the actual command line. Use LL_TEST_COMMAND in LL_ADD_PROJECT_UNIT_TESTS, LL_ADD_INTEGRATION_TEST, the big indra/test monolith and the various LslCompilerMacros. Fix run_build_test.py to pass through the test executable's own options (e.g. --touch, --output) without inspection. Defend it against the case when the platform-specific library path environment variable doesn't yet exist. Make it report errors only on nonzero test-program rc. Remove RunBuildTest.cmake.
Diffstat (limited to 'indra/cmake/CMakeLists.txt')
-rw-r--r--indra/cmake/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/indra/cmake/CMakeLists.txt b/indra/cmake/CMakeLists.txt
index 3ce393b659..4563b59ad2 100644
--- a/indra/cmake/CMakeLists.txt
+++ b/indra/cmake/CMakeLists.txt
@@ -53,6 +53,7 @@ set(cmake_SOURCE_FILES
LLPrimitive.cmake
LLRender.cmake
LLScene.cmake
+ LLTestCommand.cmake
LLUI.cmake
LLVFS.cmake
LLWindow.cmake
@@ -69,7 +70,6 @@ set(cmake_SOURCE_FILES
PNG.cmake
Python.cmake
Prebuilt.cmake
- RunBuildTest.cmake
TemplateCheck.cmake
Tut.cmake
UI.cmake