summaryrefslogtreecommitdiff
path: root/indra/CMakeLists.txt
diff options
context:
space:
mode:
authorNicky <nicky.dasmijn@gmail.com>2022-04-19 20:28:34 +0200
committerNicky <nicky.dasmijn@gmail.com>2022-04-19 20:28:34 +0200
commitd6b34d41afc1f77a28e60ae1f9e22b61323052fa (patch)
treed673e49924286318e3a25219f0507ce0104504ef /indra/CMakeLists.txt
parentca839307f9edb5f5b6807a2a7185733518c241cf (diff)
Finishing touches, making sure even with conan all needed 3ps are installed and usable.
This brings the source to be able to run tests in conan mode.
Diffstat (limited to 'indra/CMakeLists.txt')
-rw-r--r--indra/CMakeLists.txt5
1 files changed, 4 insertions, 1 deletions
diff --git a/indra/CMakeLists.txt b/indra/CMakeLists.txt
index aa0b645a64..93b9466c24 100644
--- a/indra/CMakeLists.txt
+++ b/indra/CMakeLists.txt
@@ -17,8 +17,11 @@ set(CMAKE_MODULE_PATH "${CMAKE_SOURCE_DIR}/cmake" "${CMAKE_CURRENT_BINARY_DIR}"
include(conanbuildinfo OPTIONAL RESULT_VARIABLE USE_CONAN )
if( USE_CONAN )
- conan_basic_setup(TARGETS)
+ set( USE_CONAN ON )
+ conan_basic_setup(TARGETS NO_OUTPUT_DIRS)
add_compile_definitions(LL_USESYSTEMLIBS USE_CONAN)
+else()
+ set( USE_CONAN OFF )
endif()
set(CXX_STANDARD 14)