summaryrefslogtreecommitdiff
path: root/indra/CMakeLists.txt
diff options
context:
space:
mode:
authorbrad kittenbrink <brad@lindenlab.com>2010-11-19 12:09:18 -0800
committerbrad kittenbrink <brad@lindenlab.com>2010-11-19 12:09:18 -0800
commitb6edd74775e07ce392b0a1785cfc61338c890dad (patch)
treec01e3111d3016e5f6e5453f88d8e5aa30c7ced19 /indra/CMakeLists.txt
parent1139584b026db86fd20364d0eb21b6e2351f8fb1 (diff)
parent8d21105a8c2b6bff98b4f3b91a614a4710d4b7ea (diff)
Merged latest lindenlab/viewer-development with mani_linden/viewer-development for bacground updater work.
Diffstat (limited to 'indra/CMakeLists.txt')
-rw-r--r--indra/CMakeLists.txt5
1 files changed, 4 insertions, 1 deletions
diff --git a/indra/CMakeLists.txt b/indra/CMakeLists.txt
index 8d4969a49e..d01e1869b6 100644
--- a/indra/CMakeLists.txt
+++ b/indra/CMakeLists.txt
@@ -22,7 +22,10 @@ set(CMAKE_MODULE_PATH "${CMAKE_SOURCE_DIR}/cmake")
include(Variables)
if (DARWIN)
- cmake_minimum_required(VERSION 2.6.2 FATAL_ERROR)
+ # 2.6.4 fixes a Mac bug in get_target_property(... "SLPlugin" LOCATION):
+ # before that version it returns "pathname/SLPlugin", whereas the correct
+ # answer is "pathname/SLPlugin.app/Contents/MacOS/SLPlugin".
+ cmake_minimum_required(VERSION 2.6.4 FATAL_ERROR)
endif (DARWIN)
if (NOT CMAKE_BUILD_TYPE)