summaryrefslogtreecommitdiff
path: root/indra/CMakeLists.txt
diff options
context:
space:
mode:
authorAnchor <none@none>2019-05-08 18:57:33 -0600
committerNat Goodspeed <nat@lindenlab.com>2020-03-25 18:39:20 -0400
commitb5bb0794f0022517c7aeff9a7775864a56488da6 (patch)
tree72f7c0c12a238beed2b6722e1ed44ebe316fb27d /indra/CMakeLists.txt
parent761d9aa3bff981d1f322c9fdfe33ac35b30bf338 (diff)
[DRTVWR-476] - fix linking
Diffstat (limited to 'indra/CMakeLists.txt')
-rw-r--r--indra/CMakeLists.txt5
1 files changed, 5 insertions, 0 deletions
diff --git a/indra/CMakeLists.txt b/indra/CMakeLists.txt
index 62a8f3f003..53e5d7b6a5 100644
--- a/indra/CMakeLists.txt
+++ b/indra/CMakeLists.txt
@@ -15,6 +15,11 @@ set(CMAKE_MODULE_PATH "${CMAKE_SOURCE_DIR}/cmake")
include(Variables)
include(BuildVersion)
+set(LEGACY_STDIO_LIBS)
+if (WINDOWS)
+ set(LEGACY_STDIO_LIBS legacy_stdio_definitions)
+endif (WINDOWS)
+
if (NOT CMAKE_BUILD_TYPE)
set(CMAKE_BUILD_TYPE RelWithDebInfo CACHE STRING
"Build type. One of: Debug Release RelWithDebInfo" FORCE)