summaryrefslogtreecommitdiff
path: root/indra/CMakeLists.txt
diff options
context:
space:
mode:
authorNat Goodspeed <nat@lindenlab.com>2023-05-12 09:42:19 -0400
committerNat Goodspeed <nat@lindenlab.com>2023-05-12 09:42:19 -0400
commit8e70575be833cf2056b1ceef7ef842cbc7700ce0 (patch)
treefb34033fa2010084626f371bf3ddee5f5810410c /indra/CMakeLists.txt
parent7ed52090a67882cd0bc904f1e0a9ce07cf6768e9 (diff)
SL-18837: Remove C++17 override, given build-variables change.
Until now, the viewer has explicitly set(CMAKE_CXX_STANDARD 17) with a comment explaining that we hadn't dared add -std=c++17 to build-variables/variables because we didn't know if we could build all the component autobuild packages with that switch. Now that we've successfully built all of them with that switch, we've updated the viewer branch of build-variables, so we can remove the viewer's CMAKE_CXX_STANDARD override.
Diffstat (limited to 'indra/CMakeLists.txt')
-rw-r--r--indra/CMakeLists.txt9
1 files changed, 0 insertions, 9 deletions
diff --git a/indra/CMakeLists.txt b/indra/CMakeLists.txt
index 205ce402a0..500ffa3e8b 100644
--- a/indra/CMakeLists.txt
+++ b/indra/CMakeLists.txt
@@ -29,15 +29,6 @@ else()
set( USE_AUTOBUILD_3P ON )
endif()
-# The viewer code base can now be successfully compiled with -std=c++14. But
-# turning that on in the generic viewer-build-variables/variables file would
-# potentially require tweaking each of our ~50 third-party library builds.
-# Until we decide to set -std=c++14 in viewer-build-variables/variables, set
-# it locally here: we want to at least prevent inadvertently reintroducing
-# viewer code that would fail with C++14.
-set(CMAKE_CXX_STANDARD 17)
-set(CMAKE_CXX_STANDARD_REQUIRED ON)
-
include(Variables)
include(BuildVersion)