summaryrefslogtreecommitdiff
path: root/indra/CMakeLists.txt
diff options
context:
space:
mode:
authorNicky <nicky.dasmijn@posteo.nl>2022-09-17 12:02:25 +0200
committerNicky <nicky.dasmijn@posteo.nl>2022-09-17 12:02:25 +0200
commit7a71cea15bcef59c7085657fba9ae6bdb058cc5b (patch)
treea518ac28bcf59dddea11530a2924ae22acfdd800 /indra/CMakeLists.txt
parent68c680599b3ee038a33bcad36ac52912725cf3cd (diff)
Workaround to keep old cmake versions limping around.
Diffstat (limited to 'indra/CMakeLists.txt')
-rw-r--r--indra/CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/indra/CMakeLists.txt b/indra/CMakeLists.txt
index 8386953cdc..ff6a68ff97 100644
--- a/indra/CMakeLists.txt
+++ b/indra/CMakeLists.txt
@@ -7,6 +7,9 @@
## 3.13/12 is needed for add_link_options/add_compile_definitions
## 3.14 added FILE CREATE_LINK
## 3.16 is needed for target_precompile_headers
+## Nicky: Ideally we want at least 3.21 for good preset support
+## We're not there yet, but once done, there is a kludge in Linking.cmake
+# "if(${CMAKE_VERSION} VERSION_LESS "3.20.0")" that can also be removed
cmake_minimum_required(VERSION 3.16.0 FATAL_ERROR)
set(ROOT_PROJECT_NAME "SecondLife" CACHE STRING