summaryrefslogtreecommitdiff
path: root/indra/CMakeLists.txt
diff options
context:
space:
mode:
authorNicky <nicky.dasmijn@gmail.com>2022-04-09 19:03:44 +0200
committerNicky <nicky.dasmijn@gmail.com>2022-04-09 19:03:44 +0200
commit6e1ae6ec7b70b7fc20b2593621d79430b97c8325 (patch)
tree8dd2c7d6bc2dc1f6dc0d0e9fd35e902d2113b9d2 /indra/CMakeLists.txt
parent37f652206b580e2f174f3e49753b2f702e9c932a (diff)
Raise the bar to cmake 3.13, this gives access to more modern
constructs.
Diffstat (limited to 'indra/CMakeLists.txt')
-rw-r--r--indra/CMakeLists.txt3
1 files changed, 2 insertions, 1 deletions
diff --git a/indra/CMakeLists.txt b/indra/CMakeLists.txt
index 1ab5888914..08599b29e0 100644
--- a/indra/CMakeLists.txt
+++ b/indra/CMakeLists.txt
@@ -4,7 +4,8 @@
# other commands to guarantee full compatibility
# with the version specified
## 3.8 added VS_DEBUGGER_WORKING_DIRECTORY support
-cmake_minimum_required(VERSION 3.8.0 FATAL_ERROR)
+# 3.13/12 is needed for add_link_options/add_compile_definitions
+cmake_minimum_required(VERSION 3.13.0 FATAL_ERROR)
set(ROOT_PROJECT_NAME "SecondLife" CACHE STRING
"The root project/makefile/solution name. Defaults to SecondLife.")