summaryrefslogtreecommitdiff
path: root/indra/CMakeLists.txt
diff options
context:
space:
mode:
authorErik Kundiman <erik@megapahit.org>2024-07-10 21:50:00 +0800
committerErik Kundiman <erik@megapahit.org>2024-07-10 21:50:00 +0800
commit4390609584487896c58e3a9e79d2a56116336322 (patch)
tree19dc659d4e3fb53d57fbca0a6446ae051b157d76 /indra/CMakeLists.txt
parent05c26d2e074f8210f205a674d7fb374e5f96e176 (diff)
`cpack -G Bundle` instead of `make install` on Mac
Root project finally renamed to Megapahit, which has a nice effect of CPack: - Run preinstall target for: Megapahit CPack: - Install project: Megapahit [] but it's really because CPack Bundle file couldn't be renamed via CPACK_PACKAGE_NAME like on DEB, RPM, and FREEBSD. CPack determines its own destination root folder, which is Resources (I didn't find a way to set it to Contents). fixup_bundle is now run on the .app deep inside CPack staging folders so that the dependency copies will be included in the DMG.
Diffstat (limited to 'indra/CMakeLists.txt')
-rw-r--r--indra/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/indra/CMakeLists.txt b/indra/CMakeLists.txt
index 154d83a640..d37bd7f4b9 100644
--- a/indra/CMakeLists.txt
+++ b/indra/CMakeLists.txt
@@ -12,7 +12,7 @@
# "if(${CMAKE_VERSION} VERSION_LESS "3.20.0")" that can also be removed
cmake_minimum_required(VERSION 3.16.0 FATAL_ERROR)
-set(ROOT_PROJECT_NAME "SecondLife" CACHE STRING
+set(ROOT_PROJECT_NAME "Megapahit" CACHE STRING
"The root project/makefile/solution name. Defaults to SecondLife.")
project(${ROOT_PROJECT_NAME})