summaryrefslogtreecommitdiff
path: root/indra/CMakeLists.txt
diff options
context:
space:
mode:
authorNicky <nicky.dasmijn@posteo.nl>2022-07-17 17:51:25 +0200
committerNicky <nicky.dasmijn@posteo.nl>2022-07-17 17:51:25 +0200
commit3f31d0b5a70af4ebf746d40d478b4e948e904a87 (patch)
tree140cd865990a6a892181612fd7ff1d9572c036a0 /indra/CMakeLists.txt
parentc66f444d2b3af7c5ea5220db5302b693bbc54f54 (diff)
Be more explicit: Rename use_conan_binary to use_system_binary, this will allow us to reuse the macro for more than just conan.
Diffstat (limited to 'indra/CMakeLists.txt')
-rw-r--r--indra/CMakeLists.txt8
1 files changed, 5 insertions, 3 deletions
diff --git a/indra/CMakeLists.txt b/indra/CMakeLists.txt
index 4bac78c2ef..541e29bcbf 100644
--- a/indra/CMakeLists.txt
+++ b/indra/CMakeLists.txt
@@ -17,11 +17,13 @@ set(CMAKE_MODULE_PATH "${CMAKE_SOURCE_DIR}/cmake" "${CMAKE_CURRENT_BINARY_DIR}"
include(conanbuildinfo OPTIONAL RESULT_VARIABLE USE_CONAN )
if( USE_CONAN )
- set( USE_CONAN ON )
- conan_basic_setup(TARGETS NO_OUTPUT_DIRS)
- add_compile_definitions(LL_USESYSTEMLIBS USE_CONAN)
+ set( USE_CONAN ON )
+ set( USE_AUTOBUILD_3P OFF )
+ conan_basic_setup(TARGETS NO_OUTPUT_DIRS)
+ add_compile_definitions(LL_USESYSTEMLIBS USE_CONAN NO_AUTOBUILD_3P)
else()
set( USE_CONAN OFF )
+ set( USE_AUTOBUILD_3P ON )
endif()
set(CXX_STANDARD 14)