summaryrefslogtreecommitdiff
path: root/indra/CMakeLists.txt
diff options
context:
space:
mode:
authorTofu Buzzard <no-email>2010-11-27 13:08:00 +0000
committerTofu Buzzard <no-email>2010-11-27 13:08:00 +0000
commit31a109452d743af565f99029ec835e2f32261681 (patch)
tree07375d9174730e1deec3aedcc6333fe8426cd827 /indra/CMakeLists.txt
parentb3541777921142572f735c4b028e4fba91ae80a0 (diff)
parent2f83766bb71772eda19a4c7c61896c0fd7fae8a4 (diff)
merge
Diffstat (limited to 'indra/CMakeLists.txt')
-rw-r--r--indra/CMakeLists.txt5
1 files changed, 4 insertions, 1 deletions
diff --git a/indra/CMakeLists.txt b/indra/CMakeLists.txt
index 8d4969a49e..d01e1869b6 100644
--- a/indra/CMakeLists.txt
+++ b/indra/CMakeLists.txt
@@ -22,7 +22,10 @@ set(CMAKE_MODULE_PATH "${CMAKE_SOURCE_DIR}/cmake")
include(Variables)
if (DARWIN)
- cmake_minimum_required(VERSION 2.6.2 FATAL_ERROR)
+ # 2.6.4 fixes a Mac bug in get_target_property(... "SLPlugin" LOCATION):
+ # before that version it returns "pathname/SLPlugin", whereas the correct
+ # answer is "pathname/SLPlugin.app/Contents/MacOS/SLPlugin".
+ cmake_minimum_required(VERSION 2.6.4 FATAL_ERROR)
endif (DARWIN)
if (NOT CMAKE_BUILD_TYPE)