summaryrefslogtreecommitdiff
path: root/indra/CMakeLists.txt
diff options
context:
space:
mode:
authorNicky Dasmijn <nicky.dasmijn@posteo.nl>2022-09-16 23:53:32 +0200
committerNicky Dasmijn <nicky.dasmijn@posteo.nl>2022-09-16 23:53:32 +0200
commit31341ac605f3f1ae24568af3e09b200daef77b8f (patch)
tree4ada67b06eb8585f64e22b715216aa504392f4a1 /indra/CMakeLists.txt
parent554717044f52fa39e9d42f2c5ea032efb479b280 (diff)
Settings the startup project must come *after* add_subdirectory(newview). Only after this directory is added the target will be known and can be manipulated.
Diffstat (limited to 'indra/CMakeLists.txt')
-rw-r--r--indra/CMakeLists.txt12
1 files changed, 6 insertions, 6 deletions
diff --git a/indra/CMakeLists.txt b/indra/CMakeLists.txt
index 7e70a44cf2..8386953cdc 100644
--- a/indra/CMakeLists.txt
+++ b/indra/CMakeLists.txt
@@ -106,12 +106,6 @@ if (WINDOWS)
endif (EXISTS ${VIEWER_DIR}win_setup)
endif (WINDOWS)
-# sets the 'startup project' for debugging from visual studio.
-set_property(
- DIRECTORY ${VIEWER_PREFIX}
- PROPERTY VS_STARTUP_PROJECT secondlife-bin
- )
-
if (USE_BUGSPLAT)
if (BUGSPLAT_DB)
message(STATUS "Building with BugSplat; database '${BUGSPLAT_DB}'")
@@ -127,6 +121,12 @@ add_dependencies(viewer secondlife-bin)
add_subdirectory(${VIEWER_PREFIX}doxygen EXCLUDE_FROM_ALL)
+# sets the 'startup project' for debugging from visual studio.
+set_property(
+ DIRECTORY ${VIEWER_PREFIX}
+ PROPERTY VS_STARTUP_PROJECT ${VIEWER_BINARY_NAME}
+ )
+
if (LL_TESTS)
# Define after the custom targets are created so
# individual apps can add themselves as dependencies