summaryrefslogtreecommitdiff
path: root/indra/CMakeLists.txt
diff options
context:
space:
mode:
authorNicky <nicky.dasmijn@gmail.com>2022-04-18 18:11:43 +0200
committerNicky <nicky.dasmijn@gmail.com>2022-04-18 18:11:43 +0200
commit2b151e0aefd54671e1be504269f10318d303dccb (patch)
treec1527ef5d23bc946ac8dfcb907d2678a9a96db79 /indra/CMakeLists.txt
parentdcfb94fbaca3c66ec02e6873cda53b4afd547beb (diff)
Round one to support conan for 3P packages, this allows to build the viewer on Linux again.
Diffstat (limited to 'indra/CMakeLists.txt')
-rw-r--r--indra/CMakeLists.txt12
1 files changed, 11 insertions, 1 deletions
diff --git a/indra/CMakeLists.txt b/indra/CMakeLists.txt
index 40ba284d30..aa0b645a64 100644
--- a/indra/CMakeLists.txt
+++ b/indra/CMakeLists.txt
@@ -12,7 +12,15 @@ set(ROOT_PROJECT_NAME "SecondLife" CACHE STRING
"The root project/makefile/solution name. Defaults to SecondLife.")
project(${ROOT_PROJECT_NAME})
-set(CMAKE_MODULE_PATH "${CMAKE_SOURCE_DIR}/cmake")
+set(CMAKE_MODULE_PATH "${CMAKE_SOURCE_DIR}/cmake" "${CMAKE_CURRENT_BINARY_DIR}")
+
+
+include(conanbuildinfo OPTIONAL RESULT_VARIABLE USE_CONAN )
+if( USE_CONAN )
+ conan_basic_setup(TARGETS)
+ add_compile_definitions(LL_USESYSTEMLIBS USE_CONAN)
+endif()
+
set(CXX_STANDARD 14)
include(Variables)
@@ -57,8 +65,10 @@ add_subdirectory(${LIBS_OPEN_PREFIX}llplugin)
add_subdirectory(${LIBS_OPEN_PREFIX}llui)
add_subdirectory(${LIBS_OPEN_PREFIX}viewer_components)
+if( LL_TESTS )
# Legacy C++ tests. Build always, run if LL_TESTS is true.
add_subdirectory(${VIEWER_PREFIX}test)
+endif()
if (ENABLE_MEDIA_PLUGINS)
# viewer media plugins