summaryrefslogtreecommitdiff
path: root/indra/CMakeLists.txt
diff options
context:
space:
mode:
authorErik Kundiman <erik@megapahit.org>2024-08-02 20:05:15 +0800
committerErik Kundiman <erik@megapahit.org>2024-08-03 19:33:03 +0800
commit1ebb604236b984c35c52d05f6d87f256b7f49e02 (patch)
treed29410b77d255bfdafd30bd655538465576f1e4b /indra/CMakeLists.txt
parentad9e004037349b75b992c142c1cbcff50765ba6c (diff)
Disable WebRTC on FreeBSD
Vivox even got broken here. But at least this port is still very much alive. WebRTC is not going to kill our FreeBSD port.
Diffstat (limited to 'indra/CMakeLists.txt')
-rw-r--r--indra/CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/indra/CMakeLists.txt b/indra/CMakeLists.txt
index 32f62ad681..a1eed8e989 100644
--- a/indra/CMakeLists.txt
+++ b/indra/CMakeLists.txt
@@ -58,7 +58,9 @@ add_subdirectory(${LIBS_OPEN_PREFIX}llmessage)
add_subdirectory(${LIBS_OPEN_PREFIX}llprimitive)
add_subdirectory(${LIBS_OPEN_PREFIX}llrender)
add_subdirectory(${LIBS_OPEN_PREFIX}llfilesystem)
+if (NOT CMAKE_SYSTEM_NAME MATCHES FreeBSD)
add_subdirectory(${LIBS_OPEN_PREFIX}llwebrtc)
+endif ()
add_subdirectory(${LIBS_OPEN_PREFIX}llwindow)
add_subdirectory(${LIBS_OPEN_PREFIX}llxml)