summaryrefslogtreecommitdiff
path: root/PKGBUILD
diff options
context:
space:
mode:
authorErik Kundiman <erik@megapahit.org>2024-10-20 21:10:34 +0800
committerErik Kundiman <erik@megapahit.org>2024-10-20 21:10:34 +0800
commitbdd8da4c5e4a3c2d9d58b1d72eda73c9f452c825 (patch)
tree9528828c505403e8fb4af6886a261adf7c3c3cc5 /PKGBUILD
parentceca01eb37ea7c56be87474b6488eecdf0b7c893 (diff)
Working Arch port but CEF & WebRTC are still broken
I've tried using FMOD instead, but CEF didn't work either. At first I used crow-misia's WebRTC build but it would cause a segmentation fault, but LL's build seems to break CEF. Gotta find a way so CM's build doesn't crash the viewer. PKGBUILD should be moved to indra/newview as an .in to be configured by CMake for dynamic version numbers, and adjust the instruction too to run makepkg -R from the folder where the generated PKGBUILD will be.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD14
1 files changed, 14 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 0000000000..74d9ef460f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,14 @@
+# Maintainer: Erik Kundiman <erik@megapahit.net>
+pkgname=megapahit
+pkgver=7.1.10
+pkgrel=52697
+pkgdesc="A fork of the Second Life viewer"
+arch=('x86_64')
+url="https://megapahit.net"
+license=('LGPL-2.1')
+depends=(freealut apr-util boost-libs fltk glu hunspell libnghttp2 sdl2 uriparser vlc libvorbis)
+
+package() {
+ cd "$startdir/build-linux-x86_64"
+ make DESTDIR="$pkgdir/" install
+}